Showing results for 
Show  only  | Search instead for 
Did you mean: 

Receiver won’t recognize remotes

I have Telus satellite tv (not optic) and all of a sudden my remote quit working, changed the batteries and tried to reset it and nothing. I can control the tv but the receiver doesn’t respond to the remote. Tried another Telus remote from another receiver and nothing. Please help!

I also tried resetting the receiver, and numerous attempts at resetting the remotes following the instructions on the website

@Shirl1  I have sate also. Your other receiver works properly?? This means the receiver in question ( after factory rest ) is corrupt . You have to phone into sate people go through SHOP at top of this page. polecat.

@Shirl1  My bad there used to be a phone number with the sate purchase site. Use 310 8324 to get to satellite  person

So I finally got someone on the virtual chat that helped me out. I had to remove the little piece on the bottom of my remote turn it over and reinsert it then reprogram it and it worked

@Shirl1  Never heard of this. What little piece on the telus remote. I see a screw under that ????