Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pik TV Issues

I'm a long time Telus customer, I've come to expect reliable service from Telus products. So this new Pik TV service has been quite the experience for me.

When I first got it I was told there was no need to get the box since I could use my desktop PC. So I decided that I'd try it on there. I've tried it for a few days with pretty poor performance. The service seems to be using Adobe Flash which I thought most people were phasing out so I was surprised that this "modern" Telus sorry would use it. Anyway, once I got past enabling flash, I found the video often gets out of sync with the audio and even when working the video stutters a lot. I doubt my PC is at fault as I regularly watch HD Netflix and 4k YouTube without issue and the PC is connected by ethernet to my 150mbps fibre internet service which should be more than adequate for Pik TV. I also spent over an hour on the phone with tech support who were unable to help for now. They say they will keep the issue logged on their system.

After the PC was no good, I decided I'd pick up the official Telus Android box from the Telus store since that had to be the best experience for the service. Clearly I was wrong there. The box was very painful to get going, plenty of errors encountered along the way, such as the remote being unable to be setup for my LG tv, the box randomly rebooting while I was nearly finished the Google setup process resulting in me having to start over again. It was far from the seamless easy process I usually get from Telus.

Once the box was finally operational, I was able to watch some live TV and it worked really well. Ok great then I decided to check out some of the other apps, setup Netflix etc. All went well. Then I go back to the Pik TV app and no luck. When I try to play anything I just get a black screen. What a pain. So I look online, apparently this is a common issue. I just need to reset the app and it will work. So I do that and still no luck. Now can get it to work briefly but only on Global TV for some reason usually I have to exit and reopen it a couple times to get it working and it seems to be only that channel that works. Anyway I think I'm pretty done with this thing unless there's any solution, I'm probably going to bring it back to the store. I've spent my entire day dealing with it and it's not really worth the trouble to me. Again the box connection is good, because it is also connected directly to the the router by ethernet. YouTube and Netflix are working on the box with no issues in full HD. The glitches and bugs only appear when I open the Pik TV app.

If anyone knows what I'm missing let me know.

Community Power User
Community Power User

Although I had some initial glitches at initial setup, I have not experienced the issues you describe. The device does come with a warranty, which you could choose to exercise, if you wish to continue with PikTV.

If you find a post useful, please give the author a "Kudo"