Showing results for 
Show  only  | Search instead for 
Did you mean: 

OptikTV Stopped Working on PC

Helpful Neighbour

I had been using OptikTV on my computer for a long time until recently it stopped working.


Once I select a channel to watch, the loading icon never goes away.

I have tried the following things to no avail:

1. clearing browser cache

2. uninstalling and reinstalling flash

3. multiple browsers

4. incognito mode

5. checked firewall

6. reset my internet connection

7. contacting telus support


It still works on my phone, so it must be something with the computer.


Someone else was recently experiencing the exact same problem, and their issue was not resolved to my knowledge.


Any ideas???????


Helpful Neighbour

Windows 10 Home 64 bit version 1809
Tried in multiple versions of Chrome and Firefox

Community Power User
Community Power User

I suspect something to do with Flash. I had to enable Flash for the website in Chrome before it would work for me.

Just a long time customer hoping to help.

No issues with firefox 67.0, windows 10 home 64 bit 17134.765 version 1803



@WestCoasterBC what version of windows and chrome and firefox are you using?

what else could the issue for me be? any idea?

Community Power User
Community Power User
Posted the info below

Helpful Neighbour

@FuzzyLogic i've always enabled flash. i've even tried uninstalling and reinstalling flash for good measure. none of this has fixed the issue