NEVER been able to manage channels online

Reply
malincanada
Neighbour

Hi There,

 

I returned to Telus back in August last year. Since then I have never had the ability to manage my channels online. This is what happens every time:

 

Manage Channels - 1.png

 

If I select 'Add/Remove theme packs' I am directed to this URL:

 

https://order.fibre.telus.com/web/guest/home?p_p_state=maximized&p_p_mode=view&saveLastPath=0&_58_st...

 

and this is what I see:

 

Manage Channels - 2.png

 

If I select either of 'Add/Remove premium services' or 'Add/Remove channels' I am directed to this URL:

 

https://order.fibre.telus.com/digital/select?LPDSID=1626329&INTCMP=RA_Optik_Customize&action=customi...

 

and the page never loads. I just have the little spinning circle for eternity.

As per the subject line this has been the case since August when I re-joined Telus.

 

I have been on onto online chat a couple of times in the last two weeks and they alternately told me:

 

the problem was my browser

a report had been submitted

it would be resolved soon

there is no known date for resolution

this is something specific to my account

this is something that happens to a lot of customers

 

So that was very helpful!


Is there ANYTHING being done?

FuzzyLogic
Coach

FWIW I've had similar experiences. When I go to the Telus login screen they are pushing their app to ("it's easier on the app"). The last time I attempted to get anywhere on the website I usually got a blank page at some point and couldn't continue. I was able to get farther with the app.

 

I'm planning to make some changes this weekend. It would be nice if I could actually do it on my own vs working with support.

malincanada
Neighbour

You've been able to use the app?

If I try and use the app I get the message:

 

"Traffic is very heavy at the moment. It may take a little longer than usual to fetch your data."

I have seen that message every time I've tried to use the app to 'Manage your subscription".

 

Business must be great if traffic has been that heavy since August 2019...even at 2:30am.

FuzzyLogic
Coach

I'm not seeing this on the app. I have issues with it 'knowing' where I am as the app thinks I'm in Ontario by default and says that Telus TV service is not available there. Once I change to the correct province I am able to access my plan/bundle info. 

FuzzyLogic
Coach

Tried today to actually makes changes and no luck. I was using the app and was unable to get past a particular section. Web page was totally unusable. Currently been waiting about 20 minutes with chat to hopefully get my changes done:-(

FuzzyLogic
Coach

Got it sorted. Here is an excerpt from the chat as to why I couldn't make changes with either the app or website:

 

And for the reason why you are unable to process the change is because the package you want to have needs to be done here on our end since this requires a migration of your TV package to new TV package