Cant Link Telus Home Assistant to Google Home

Reply
Highlighted
Neighbour

Hi, 

 

I have been trying to troubleshoot linking my Telus account to my google account so i can use voice command to change channels on my TV.  I get to the part where I enter my email and password to my telus account, then it tries to link, then i get a error message.  It says " Linking your Telus home assistant account" then it says "Couldn't update the setting.  Check your connnection"  Any help would be appreciated. 

 

thanks, 

Robby

Highlighted
Resident
Same issue here would like to know what to do to fix. Was working on beta but now it is not.
Highlighted
Resident
Don't bother enabling the Google assistant. The supported commands are useless unless you have a remote control on you which defeats the whole point of voice control.
Highlighted
Neighbour

Update: Telus has fixed this problem.  You can connect normally now. 

Highlighted
All-Star

Good to hear and thanks for taking the time to give us an update. Many people just move on once they get their problem resolved and leave the rest of us hanging.

 

I recall that it took me a few tries to get mine linked but I don't remember what I did to get it to work. I have 2 other Optik boxes I haven't linked yet so maybe it will go smoother now.

Highlighted
Resident

I have been trying unsuccessfully just to make the google assistant work on my Optik TV. I have only attempted via Android Smartphone and have successfully linked my TELUS app, it shows my TV box with the nickname I typed, BUT when I try to say a command ("Hey Google, show me Game of Thrones on <device nickname>) all google assistant does is pop up website links on my phone. Have deleted everything and relinked. Have tried on 2 different STB in the house. Same issue. Literally starting to go a bit crazy over here. What am I doing wrong? Thanks in advance.

Highlighted
All-Star

@Helpplease wrote:

I have been trying unsuccessfully just to make the google assistant work on my Optik TV. I have only attempted via Android Smartphone and have successfully linked my TELUS app, it shows my TV box with the nickname I typed, BUT when I try to say a command ("Hey Google, show me Game of Thrones on <device nickname>) all google assistant does is pop up website links on my phone. Have deleted everything and relinked. Have tried on 2 different STB in the house. Same issue. Literally starting to go a bit crazy over here. What am I doing wrong? Thanks in advance.


I'm not sure if that was just a typo or not but you need to link to the TELUS Home Assistant service (not the my TELUS app) from the Google Home app.

Instructions are here:

https://www.telus.com/en/ab/support/article/set-up-telus-home-assistant-on-your-google-home-device

 

Note that step 4 in the instructions "Select Have something already set up?" is referring to the section under Works with Google not the section New devices.

 

I suggest trying some of the sample commands suggested here to test your setup:

https://www.telus.com/en/ab/support/article/telus-home-assistant-beta

 

Make sure you name your optik box something distinctive that won't be confused with another device. Calling it TV may not be good.

Highlighted
Neighbour

When i tried using a android smarphone to turn channels, the same thing happened.  It just brought up web links.  I have a google home mini and it works.  Sorry I cant help. 

Highlighted
All-Star
Can you use your phone to do other commands like send a message? If not then the Google Assistant isn't set up properly on the phone.
Highlighted
Resident
Did you get a solution? I cant link either.