Almostb24 hours and ordered channels are not showing up


This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Just Moved In
I subscribed to some channels almost 24 hours ago, through my remote, and accepted the additional $6/mo. These channels are still not showing up. Yet, on my account, the charges have been added. I’ve tried restarting the box, and nothing happens. If I try to subscribe again, or to subscribe to anything else, a message comes up that there is an order pending on my account and that my request cannot be processed and to wait 15 minutes.

Of course, you can’t get through to anyone at Telus to resolve it, and the online chat is completely useless. For 200 bucks a month, this is a rip off. I’ve been with Telus for a long time and this has never been a probkem. Anyone have any ideas as to why this is happening?
Community Power User
Community Power User
Depending on the channels added it can take up to 24 hours.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

I substituted one pack for another online.  Message says it will take UP TO 15 minutes.  That was 2 hours ago.