Showing results for 
Show  only  | Search instead for 
Did you mean: 

Has anyone had issues trying to change home account password (registration "temporarily down")?


I was wondering if anyone else has had trouble trying to change their home account password. 

I can access my account without any issues.  However, I would like to change the password.  I have tried a couple of times each month for the past year.  Each time I try I get a message telling me "Looks like our registration system is temporarily down".  I have tried on multiple computers and tablets, using Explorer, Chrome, and Safari.  I have tried at different times through the day and evening.  The result is always the same.

I am reluctant to call customer support.  I have learned the hard way that the only time I have had issues with my service is after calling customer support.



Community Power User
Community Power User

Telus has been revamping that interface for some time now, and clearly the task is not yet complete. The issue is not that of your browser, but the back end of the interface. Unless you have some very real need to change your password, or are worried about it being compromised, you could keep trying in the manner you have, or ask for help by calling in. 

I am not aware of a date for resolution, but I, too, am looking forward to seeing the interface fully functional. 

If you find a post useful, please give the author a "Kudo"