Showing results for 
Show  only  | Search instead for 
Did you mean: 

No internet when data on

Phone shows data on and lte arrows show transmission yet I go on a web page and it says no internet

Community Power User
Community Power User

All web pages, or only some?


Have you tried re-starting your phone?


If you find a post useful, please give the author a "Like"

and if I hotspot my phone Use my fire stick Same thing says connected but no Internet available


Did this just start happening recently?


What make of phone?

It's since October when I switched to tellis and go out a Samsung S20 It will even do it on Wi-Fi sometimes too It also does it on my Samsung tablet I had phone tell us and they were going to come but somebody from their other department phoned and turned off some of my Wi-Fi and said to let him know how it worked it worked for a while and I emailed him back and he has never responded all responded all he did is shut off my Wi-Fi on my router and left the booster one on bottom if the booster went on but as I mentioned it also happens with my data

I would  try turning off the power to the boosters and see if you can get  a wifi signal  and internet access from the  adsl modem.


If you turn wifi off on your phone you should have internet access, but you will  be using data from your mobile data plan.

I think you missed the issue My data and Wi-Fi show being on I get a written message saying No Internet My phone shows the arrows on the top and that the data is on and it is communicating

Up arrow means it's sending. Down arrow means it's receiving. If you don't see the down arrow that means there are no responses to the requests, i.e. no Internet.


You mention both WiFi and Data. Are you having this issue when connected to just WiFi, just mobile data or both?

If you are to access the internet when you are other locations than your home then the problem is with your home router or booster.

If you think it is wifi on your phone try using wifi at a coffee shop or other free hotspot.

I have had similar problem with my Samsung phone when it connects to hotspots that have broken internet connections.

Yes both And then a guy a teller shut off the router and only allowed the booster to put out If that helped for a couple of days and then I noticed my data when I was not at home doing the same thing

If you able to access the internet when using a free WiFi Hotspot then it very likely the problem is with your home wifi network. 


Do you have any computers connected to the router?


Do you have telus TV? 

Turn off wifi on your phone and see if you get internet access.

If wifi is turned on LTE will not be used for internet access.


When you switched did you bring the S20 over from another carrier or did you get the device with TELUS?


If it was a device the was previously on another carrier and your mobile data is not working may have to change the APN settings in your phone. The TELUS guide for setting up for the TELUS APN can be found here: it would be the same for the Samsung Tablet if it is cellular enabled and attached to a Peace of Mind Connect or Simple Share plan.


If the device was purchased from TELUS then it should already have the correct APN settings and I’d call in to try and troubleshoot the mobile side and if still isn’t connecting to LTE or 5G may just have a faulty device that would need to go in for repair.