Data won't activate iMessage on iPhone 7 Plus.

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Resident

Hi I recently signed up for the 10GB for $60 plan. My data is not working with iMessage. It works with other applications but, when I try to activate iMessage with my data on, I get an error message saying that I need to have my data on. I already restored my phone and reset the network settings and still no luck.

 

Could someone please provide a solution to this? 

 

Thank you.

Highlighted
Community Power User
Community Power User

Do you have cellular data shut off for the Messages app in the main system Settings? Settings > Cellular > scroll down and find Messages. If the toggle is grey that means Messages can't use cell data. Tap it green and try messages again.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Resident
Yes my data is fully functioning, I cannot turn on my iMessage using my data. It is green on the cellular menu and the main system settings.
Highlighted
Friendly Neighbour

i have the same issue, did you find a solution 

Highlighted
Community Power User
Community Power User

There have been a number of reports of this on Koodo’s community a well, so I expect a resolution is coming.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
Connector

@Nighthawk wrote:

Do you have cellular data shut off for the Messages app in the main system Settings? Settings > Cellular > scroll down and find Messages. If the toggle is grey that means Messages can't use cell data. Tap it green and try messages again.


FYI, there is no such toggle on the Settings > Cellular > screen.

Highlighted
Connector

@jcp_03 wrote:

Hi I recently signed up for the 10GB for $60 plan. My data is not working with iMessage. It works with other applications but, when I try to activate iMessage with my data on, I get an error message saying that I need to have my data on. I already restored my phone and reset the network settings and still no luck.

 

Could someone please provide a solution to this? 

 

Thank you.


Just want to post that I too just signed up for the $60/10 GB plan but iMessage is working normally for me using cellular data. I'm on an iPhone 5S though but I doubt it makes a difference.

 

Hard to say if this is a Telus network problem or an iPhone/iOS problem at this point.

 

Does it work on WiFI?

 

Here is a link to an Apple support document with troubleshooting tips: https://support.apple.com/en-us/HT201422

 

There are a bunch of troubleshooting tips in this article as well.

https://www.iphonelife.com/content/imessage-not-working-try-these-troubleshooting-tips-to-fix-it