Showing results for 
Show  only  | Search instead for 
Did you mean: 

Any suggestions to get Apple Watch 3 LTE activation to work?


I currently have a ticket raised to see if tech support can figure this out, but while I wait, any suggestions on how to get Apple Watch 3 to activate?


Seems like I've tried just about everything:

- Telus has confirmed that my account plan will support the Apple Watch (sharable data, etc)

- changed SIM cards due to previous plan was on the corporate plan (as suggested by tech support)

- un-paired Apple watch and re-paired it to see if activation would be successful

- tried resetting 'network settings' on iphone


Anything else I can try? The issue is I keep getting the message to contact Telus after I click on 'Set up Cellular'. That's as far as I get.



Community Power User
Community Power User

Wondering if somewhere in the bowels of Telus' IT department, your account is still reporting as corporate..........

If you find a post useful, please give the author a "Kudo"