Showing results for 
Show  only  | Search instead for 
Did you mean: 

will Unlocked LG G3 (model D852) fully function With LTE on TELUS?

Just Moved In

I would like to buy the LG G3 from a Canadian carrier (Rogers or Bell), pay to have them unlock it, insert a TELUS sim card, and be able to use the LG G3 LTE coverage on TELUS.  


Does TELUS'  LTE spectrum/band fully function with the LG G3 D852 Canadian model?  Please let me know.


Thank you



If it's from Bell/Rogers, yep. 🙂

iPhone power user

Make sure you check the Lte bands of phone from both carriers. Rogers & Bell. I know the Lgg2 from Rogers would only work on 3g with Telus and not Lte.

Thank you for mentioning this, it's the reason why I posted my question here.


Can someone please confirm if the LTE bands of the LG G3 D852 are compatible with TELUS?

I think that Rogers/Bell/Telus use same LTE band (Band 2100). Thus, if the device is unlock, it should be work in TELUS network even though G3 from Rogers.


Just Moved In

Did you manage to get one from Bell or Rogers? I want to get one that it seems they force you to sign up with them even if you are paying for it right out. I went through the checkout process on the Bell and Rogers websites and you HAVE TO select a plan even with no contract. I'm NOT changing my provider and I just want this phone. No plans, no contracts. Just the phone. 

I think your best bet would be to go buy it straight from one of their stores.

Friendly Neighbour
trelarah, did you get the G3? I just got a used one but no matter what I tried, I can't get the data network to connect. My carrier is Telus, and according to the specs, it should be fully supported. My G3 was unlocked successful. I can make calls with it but no data.
I tried going into the Hidden Menu and change the WCDMA or the LTE settings but it seems read only, the actual value doesn't change.
If you got your G3, did you manage to get the data working?

@Knguncl3 It sounds like you haven't updated your APN settings. If you managed to get voice and SMS working, it means data will work as well. (Note: this is because telus does not have a 2g network, which means you are indeed connected to their 3g network).

To update the APN settings follow these steps:


Step 1. First, browse your Settings menu and find the “Access Point Names” menu.  This is usually under “Mobile Network Settings” or “More Mobile Networks” or “Mobile Networks” under Settings menu depending on the Android device used.


Step 2: Add a new APN:


Manually type in the following information:


Name: Enter any name


Proxy server: leave blank

Port: leave blank

Username: leave blank

Password: leave blank

Server: leave blank


Proxy server:

Port: 80


MNC: 220

Authentication type: None

APN type: default, mms, supl

iPhone power user

Thanks Dark_Knight.  It's working now.  And it was something wrong with my APN entries.  I ended up getting someone else to try to get my phone working.  The other person messed around with it for about 10 minutes and got it work.  I compared with what I had, he basically left out the "APN type" and got it working.

Before, I had "Internet+mms".  I tried different combination of that.  e.g. with space in between, comma, + sign, etc. But I cannot get it working.  But I'll create a new APN profile and try what you suggest for APN type and if it's just a syntax issue.


Also, just FYI for anyone to got the Roger's version of the G3, I think I had to flash the Bell stock ROM in order to get it fully working.  You see, with the Roger's stock ROM, the preferred network mode has GSM / HSRP / LTE.  Where as with Bell and TELUS, we get GSM / WCDMS / LTE.


Now that I know one of my problem was with the APN entries, I'm not 100% sure whether that was the only thing needed.  But I suspect you need to flash the Bell stock ROM as well, just like what I did.