old mobile devices

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

wally_west
Ambassador

Do you guys remember what was your first mobile phone? Me, motorola Star tac, analogue service only Smiley Happy 

Just having fun and sharing, cheers!

Community Power User
Community Power User
Audiovox CDM9160, if I recall.
NFtoBC
If you find a post useful, please give the author a "Like"
Dark_Knight
Rockstar

Mine was the Nokia 5190. I rocked it with one of those flashing antennas and weird faceplates. lol

iPhone power user
Highlighted
Moderator
Moderator

Memories...my first first phone was also analogue only, Nokia 282, flip phone, no color screen but it was actually good looking. Thanks for sharing everyone Smiley Happy

Moderator
Moderator

Dark-knight, I remember using a Nokia 6185 and yes, we were able to change the cover on it as well.

xray
Rockstar
My first phone was an Audiovox MVX. Can't remember the exact model, 480 maybe. Cool and expensive at the time. Had as much computing power as a singing birthday card.

Now I'm feeling old. Thanks a lot. Smiley Wink
Dark_Knight
Rockstar

You aren't old @xray just experience at living life. Smiley Tongue

iPhone power user
Community Power User
Community Power User

My first phone was the Sony Zuma...

zuma

 

I think it was the first digital phone from Telus.  Battery life was not the greatest, but having the mic arm to answer calls was my fav feature.  I had it for 6 years before a fatal drop broke the antenna stalk.

NightWing-Robin
Organizer
Memory Lane Bonanza! Mine was the Bat Signal... didn't have great range though, eh @Dark_Knight? Smiley Wink
Moderator
Moderator

Wow... mine was the Sony CM-B1207 back in 1998... I remember loving the ability to check movie show times, send/recieve texts/messages, backlit LCD screen, being able to go day(s) without charging... navigate using the quick jog-dial on the side, and it just looked cool (back then)...

 

sony-clearnet.jpg

sony-clearnet2.jpg

 

 

v9
Rockstar

 Kudos to Wally-West for this 'Post' get out a bit from, daily routine of cellular bugs, Wrong Telus bills, posts without texts,.etc. comes handy to release the stress- isn't it ! . Let's ge to recall old.mobile Phs

 

Mine was a "Motorola-V120X" I bought in Flea-Market in 1994, connected with "Clear.Net" By the way @ Dimo-x. How didyou post the picture of your 'Sony' I searched for old phones, found mine, took a picture, couldn't uploaded. I click images in toolbar, display a screen I select browse, sendMe to My 'Docs on My Pc' get stuck there.

 

To close my post I like the 2nd slogan of "Clear.Net" [(What you get-What you pay). I'd add this (What you signed-What you pay)] I'd suggest -Telus- adopt this 'Slogan' to boost its sales,. Huhuuhaha!  <ReadMe soon>  "V9"

 

 

@v9-12 yrs.Telus mobile user & Ex-BC Tel cable installer.
Find this reply useful-Give likes to his author
The future is unknown?
wally_west
Ambassador

Thanks v9, it's amazing to see everyones comment.  I also remember using the motorola v3620, the smallest phone in 1999. 

tsizzle
Leader

Ericcson T10, still works when I turn it on.

Mauller
Connector

Mine was an SCH-3500 from Samsung.

 

First phone

Moderator
Moderator

I remember this Samsung device, back in 1999-2000, it was one of the search with voice dial and I think you had to enter to record the names inside in order to use it. It also had flip issues. I remember the t-130 from Samsung and the a-500, one of the first with a camera.

Moderator
Moderator

@V9 That's odd, just like you I searched the inter-webs (heh) for the model, saved the image and then selected the insert/edit option on the toolbar (withthe fonts, emoticons and what what!) and pointed it to where I saved the file... hmmm... Maybe try a different browser or link to the image via the insert/edit link?

 

@SuperFred Flip issues? hahahah wow... that sounds like a pain... I would go 'flipping" mad... sorry... couldn't help it! 

v9
Rockstar

Thanks-Dimo-x: For your input, about how to upload a picture or any image to post. I reviewed the procedure outlined, for you N' I screwedup, 'cause I took a photo with my "Ss4" then I wrote the post, open my (Photo folder) try send it as an attachment.

but I clik the image(icon) not the (insert/edit option)

 

@ [Dimo-X] If you've time to reply, those Moderators like "Nf to BC" who have changed, their picture did they follow the same process to upload it. Reason is that I'm not satisfy, with my "Bear avatar photo" asigned by the system, when I signed in. I've seen 2More guys, withe same animal. Is there any permission to request to (Admi.. board) to changed? waitforeply  "v9"

@v9-12 yrs.Telus mobile user & Ex-BC Tel cable installer.
Find this reply useful-Give likes to his author
The future is unknown?
Community Power User
Community Power User
Just follow the instructions in the profile section to upload a new avatar. You will need an image of the correct dimensions.
NFtoBC
If you find a post useful, please give the author a "Like"
v9
Rockstar
Thks-NFtoBC: I haven't had time to re-read that section. I'll do so Asap if unable to upload my selected image, I let them know for additional help. <ReadMe.soon> "v9"
@v9-12 yrs.Telus mobile user & Ex-BC Tel cable installer.
Find this reply useful-Give likes to his author
The future is unknown?
Community Power User
Community Power User
@v9 BTW, I'm not a Mod.
NFtoBC
If you find a post useful, please give the author a "Like"