Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus mobility app for Android

So I have a samsung galaxy s7 edge and I am no longer able to login to my telus app, I am not a corporate user or business person, it just says when I try to login it says (Sorry there is a unexpected error logging you in please try again later) I tried to uninstall, reinstalling the app clear system memory, no luck. I use this app every day, and help would be great thanks.

Community Power User
Community Power User
@Matt365 Delete the app and restart the phone, then reinstall the app. See if the issue persists.

Tried that just now, no change, unfortunately I might have to factory reset my phone, something I really never wanted to do, but at this point there really is no other solutions, I don't believe that it's telus mobility app causing this problem, it can only be one of two things other app interruptions or Android N software problem.I guess I will try a reset

Community Power User
Community Power User

It's entirely possible the app is not yet compatible with Nougat. I have the exact same error with it on my S7 and S6 Edge. I'd say wait until they release an update.


For now, try accessing your account online instead.


cc: @ScottyJ

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

In regards to the My Telus Account App, I had an issue over the weekend.  Everytime I tried to log in I got an error message "unable logging you in. Please try again later".  I connected to the chat feature, spoke to Katherine who was absolutely the best at trying to help me fix this issue.  She coached me through the steps to provide the information she required.  This morning I tried to log in with my email address and password.  IT WORKED!!! RIGHT ON!!! Now whenever I am away from my computer I can access my account.  Thank You once again Katherine!!! MOST APPRECIATED!!!