Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Network. "Searching..." for hours

Just Moved In

For a few hours now, iPhone6+ has been sitting "Searching..." for the network. Restarted the phone, switched between Airplane mode, toggled cellular options off/on, factory reset Network settings, and checked my SIM card. Now waiting on an Apple update (10.2.1) to see if it makes any difference.


Would call support, but from past experiences I'd rather not be talked down and listed the same troubleshooting steps I've already taken. Not the first time I've had this *exact* issue with a Telus iPhone near the end of a contract.


Is it my device(s), or Telus being incompetent as usual? 


Just Moved In



iOS update completed, carrier update as well - now NO SERVICE whatsoever, no "Searching...".


I'm done with Telus. 

While rare, it is possible you are in an area temporarily without service. Have you tried moving to another place to see if cell service is available, or are you already in a location where another phone is receiving service?


If you find a post useful, please give the author a "Kudo"

Ask telus to give you the unlock code for that device put in a bell or Roger sim enter the code and let it discover your new carrier then power down and reboot with your telus sim again.


I had the exact same issue with my iphone 6 64GB.

Also, you can notice that the carrier setting is missing.

Settings->carrier (that's where you can turn off the automatic and search for network manually)


Went to Apple store, tried different sim, reloaded software, nothing works.

Apple can't do anything since I don't have warranty, just offered to get a replacement iphone 6 for around $400

Bought a New Iphone 7 plus.  Then few weeks later, the carrier setting show up by itself.

I don't think it's a carrier issue.  Cos my wife was using the phone on Rogers network.

Not sure how many ppl have had this issue.