Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webmail/Telus email is currently down.


Just a heads up - our webmail is down at the moment. The queues are very high. Please be patient! We are working on it! So sorry for the inconvenience!

613 REPLIES 613

While my email has been restored, it seems to take an awful long time to download messages - far longer than before the outage. Is anyone else having a similar experience?

Much the same for me. Unable to access webmail for the last 24 hrs. Prior to that many emails were empty and could not be erased.

Still getting "Looks like we can’t find that page." when trying to sign into webmail 

Community Power User
Community Power User

Webmail is working fine for me.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

My webmail has been restored with all the LH side files BUT still having no luck with deletions.  Strange thing is, I can delete ones that have just arrived even after reading them,  but any that came in earlier-opened or not, will not let me delete.  I now have over 20 sitting there..can't even move them to Trash or Junk....any ideas ??

Follow-up to the above...I CAN delete any emails that are in my Trash or Junk box, but nothing that's sitting in my Inbox. ???

@Irishgranny Allow some time for your mailbox to be fully restored and 100% functional again. It will get there sooner or later.

I can access webmail this morning and delete emails. I had quite a few 'empty' emails before which have disappeared on their own. Still can't access email on my desktop email client.

As of this morning, I cannot access webmail at all.  I get a 500 server error.  Cannot change password, cannot access email whatsoever.  This was supposed to be fixed.  No Telus chat agents, and I'm pretty sure that I don't want to sit on hold to inform them of yet another **bleep** up.  This is getting stupid now.

My email seemed to be working Wednesday, but stopped working last night. I wasn't able to access webmail yesterday. Today I am able to access webmail, but Outlook keeps asking me to confirm my information for my account.


It's strange that service was restored, but is no longer working fully.

I suspect that it might take a while for telus to iron out all the bugs in the new servers and provide stable uninterrupted service. As I posted earlier, it now takes a long time for messages to download, whereas previously it was virtually instantaneous unless there were large attachments. However, no such problem on sending messages.


I went through the long online wait yesterday and spoke to telus, talked to three people in all. I tried to explain the POP3 server is throwing errors ( the one causing your outlook to to ask for your information). I got ridiculous suggestions like "delete all my cookies", remember we are not talking webmail but standalone email clients ! Not the support people's fault, most of them have not even heard of POP3 or SMTP. If email addresses could just follow us like telephone numbers do I'd drop telus completely in an instant.

@MrE wrote:

If email addresses could just follow us like telephone numbers do I'd drop telus completely in an instant.

I don't doubt that a lot of people share this sentiment.

Seeing "Mail server responded: pop access not enabled for account" on one of three email addresses I have with Telus. The other two have been fine for a week or more.

Looks like they're still working on it. Webmail has lots of old emails this morning including some dating back to July 26. Most of these have no content just "Missing Blob for item nnnnnn" and can't be deleted giving a "A network service error has occurred." error.

Hi All, I have family email users on my Telus account who rely on a standalone email client (Windows Live Mail), and their friends have been phoning to express concern because email flow stopped around 3 weeks ago.  The unique thing about it is that the only recipients / contacts affected by the interruption are people who have accounts / email addresses with SHAW.  We are using webmail to bypass the problem temporarily.


I experienced the identical problem nearly a year ago and appreciated help troubleshooting on this forum.  For reasons that I still don't understand, the problem turned out to be a defective modem: we replaced the modem, and the Shaw incoming and outgoing emails started flowing again.


This last weekend (Sept. 1), I tried to phone Telus tech support to get help and was told that THIS TIME, the problem is NOT modem related, it is server related (associated with last month's big outage). Rather than replace the modem, I was urged to do nothing and live with the problem for a while longer with the expectation that email contact with Shaw clients would be restored shortly. Can the experts on this board confirm that this makes sense, or should I get on the phone again and request a new modem?  I am so annoyed over this that I want to smash something.


If this overlaps with previous discussion on this thread, then my apologies: please post a link to the relevant post/s and I'll try to do my own due diligence. Regards

Community Power User
Community Power User

@MyrmidonThere was multiple server issue which resulted in restoring (from backups) customer email accounts. You must wait till the account is restored and be fully functional again. In the mean time use Telus webmail which should give your partial functionality. Or use an alternative email address other then Telus till the issue(s) are fully resolved.


All updates are here.

Thanks. We received notice back on August 26 that "your historical emails and contacts should now be restored and are accessible in both webmail and all other email applications (including your smartphone and tablet applications)."  How that could affect NEW incoming and outgoing messages to Shaw addresses is a mystery to me, but if you say it's still work in progress, I guess I have to take your word for it.

Me again!  All mail working great now..have my address book nagging problem. I can delete or move new emails, but have a good dozen or more old ones that just won't let me delete or move them.  Is this going to be a final result ?  Strange that I can delete new mail but not the old ones.  Just a minor glitch that's annoying...thankful for everything that has been restored.

I would have to assume they’re not done fixing it all. Priority is obviously sending and receiving new mail first.

Email is still broken, this is not just a restoration problems.


How does someone get Telus to pay attention to ALL the problems with the email. For almost 2 weeks I wake up to (and find several other times durring the day) a requester stating ...


Server responded: -ERR system failure: unable to look up account during query 

... my logon info

LDPA error: unable to get connection; ldpa host:= An I/O error has occurred.


When I report this to telus they tell me unrelated things like clear my cookies! This is NOT WEB MAIL. The Telus server is clearly stating it is an internal error on there end.