Showing results for 
Show  only  | Search instead for 
Did you mean: 

UK VPN stopped connecting on Arcadyan Fibre


I have been using an Arcadyan fibre modem for a while. For years up until May 21 (both on Shaw previously and then subsequently on Telus fibre), I have been successfully connecting to a VPN in UK, without any issues. On May 22, 2021 that changed! Now it dials, verifies, but will not complete the connection - this has been happening for days now.

I tried rebooting the modem, the boost hub and even the fibre hub unit (where the fibre enters my house), all with no success.

But I have confirmed that it is definitely a Telus problem, as follows - it used to work, but now fails, on 3 separate computers as well as on my phone (so it is not the device, hardware, software, setup, etc.); it still works on my computer when I connect via a different ISP (Shaw), and also connects to the VPN on my phone when on the cell network only, with Wifi turned off (so the problem is not the VPN server, password, etc.).

Has anyone experienced problems with connecting to VPN, and have any suggestions on how to fix this? If I cannot resolve it, I'll be switching ISP again.


Have you tried resetting the router? (Hold reset button with a pin for ten seconds, instructions on Telus support site)

If that doesn’t fix it, I would suggest contacting Telus support. I use a few different kinds of work VPNs on the Telus fiber network without issue.

OK thanks - maybe I'll give that a try, although doing factory resets always makes me nervous!

Seems to have fixed itself, without further action.