Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus webmail down yet again


This is happening all the time why is this?


Hey guys!

Webmail is in fact down. So sorry for the inconvenience!!! It has been down for the last few hours.


Here is the status: 

Issue Details:

Error and latency is experienced within webmail
  • Users are delayed or unable to access their email services

Actions / Updates:

INITIAL - Apr 17, 17:08 ET
  • Issue is isolated to email accounts whose password was just changed
  • Support teams continue to investigate, no ETR

We do not have an ETR but the fact it has been reported is great and we are on it to fix ASAP! Hang tight and thanks for your patience.

View solution in original post

132 REPLIES 132

I'm having problems logging on and keeping a connection with my Edge and Firefox browsers too.

Just got off chat with support.  They are still working on the problem.

Yes!  Been having issues since last night.


Over a week now.

Trying to log in to webmail from remote computers in Ontario and cannot stay logged in using 3 different browsers (FireFox, Chrome, Edge). Stay logged on for about 30 seconds and then bunted out to login screen, it is really aggravating and troubling, my email client (MS Outlook) is likely working OK but it is on my computer back home in Alberta. Oh well, Too Bad, So Sad...

My Telus email has been down for about 3 days in Abbotsford BC .. just checked 5 minutes ago .. won't take password retype it .. error code xxxxxccc92

Can’t get through to anyone at TELUS using chat - #250+ in queue and then it just disconnects me at random after waiting in line for a few minutes (4x I tried and got booted off every time?!). I tried calling, but endlessly on hold there too.


Their email service has been down since yesterday afternoon, but not surprisingly, the billing pages are up and working. Sorry if I sound a little cynical, but having no email service on any devices, local mail client or web based for nearly 24 hours now begs the question why they don’t have any backup service.

I have not been able to get in since yesterday afternoon

 Then this morning it worked for a bit  then closed me down again.  since 9am

yup, since yesterday, I'm in Alberta


I am on my phone and I cannot get e-mail.

It is the only way I have of communicating at this time.

Hope the problem is solved soon.😕

This has been a big hit to my online business. I am beyond frustrated !


I am on the mainland Lions bay

The link is fixed. Great.  But there is exactly zero new information.  The link leads to a post that's 24 hours old.  How about a real update with a real explanation?  Better yet, how about getting the service working again?  Email is not exactly cutting edge technology anymore and this is supposed to be a core competency for an internet service provider like Telus.  Yet you struggle to keep the service working.  Seriously, what is up with that?

While you're down I'm spending my time researching alternatives.  


Community Power User
Community Power User
The report of the incident has been updated a number of times since first created, however, none with a time of resolution. Until Telus finds the issue, it is impossible to post a timeline to resolution.
If you find a post useful, please give the author a "Kudo"

Can't log into email service, but their billing site is working flawlessly - no log-in or password issues there!

The report has not been updated in any useful way that I can discern.  It is exactly the same message I've been seeing all day.  The gist is "we don't know what's wrong and we don't know how long it will take to fix it".  Just to be sure I'm linking to the correct non-information, I've copied and pasted below.  So, if you have the chutzpah to assert that "the report of the incident has been updated several times", then, show me the changes over the past, say, 8 hours because it sure doesn't look like an update to me.


Service(s): Webmail services
Impact(s):  Interruption of services

Start:  2018-04-17 16:04 (ET)
Status:  We are currently investigating the cause and working to restore services, but do not have an ETR at this time
Root Cause:  Undetermined at this time


Issues: Webmail Services are experiencing an interruption which may result in being intermittently unable to connect to the service and being unable to reset email passwords. We are working to restore services as quickly as possible. Further updates and estimated restoration times will be provided as they become available.



Community Power User
Community Power User


  Since I did not keep a cut and past of each iteration, I can't prove to your satisfaction there have been changes, but this morning, there was reference to being able to access mail through clients on computers and tablets, and links to the process to set up such clients. These have since been removed. While the substance has not changed - there is still no timeline for restoration of service, there have been updates to the information contained in the message.


I agree that Telus could manage this better.

If you find a post useful, please give the author a "Kudo"

Just did a test. It appears to be stable and working for me.

I was able to delete emails, change folders and read emails without being logged off.

How does it look for others?

Mine seems to be working for now....

Same here.... I've been stable for the last hour.


Lots of emails to read and delete.

At 19th April 2018 0705 EDT able to access email via webmail using Chrome browser and all seems OK. WhooHoo!