Telus Home Assistant/Google Home - not linking/broken


Telus Home Assistant/Google Home - not linking/broken



Any idea why this is not working? Id like to link my Google Home to my Telus Account so that I can voice control my OptikTV box via GH but I cannot because of some "broken link"


I realize this is beta, but I'd also like to be part of the beta program if possible.






Community Power User

What steps are you taking?  I had some difficulty setting it up at first, as it wasn't properly loading on Google Assistant. I also believe you need to be on Fibre.


If you find a post useful, please give the author a "Like"

Thanks. I'm following the instructions on the link, but where the problems arise is when I log in into telus with my credentials on my Wi-Fi (fiber) it says "couldn't update the settings. Check your connection" that's where it stops.

I have been trying to setup mine for almost a month now. Getting the same error every single time. Followed the instructions mentioned in the post but getting the "Couldn't update the settings. Check your connection" error.

This is what I found out, right now, this is only open to telus employees. They will open to some customers on Jan 28. Call the optik fiber team, they can put you on the list of beta testers. The list is not open now so I will call back on Jan 28.

I was able to connect Telus Home Assistant in the Google Home app, but when I ask my Google Home to control the Optik box (change channels, for example) it says it's not there.   I've just started playing with it so hopefully it's just user error.  

I did a bit more playing with it and found that it worked with Google Assistant on my phone, but not our Google Home.   Intriguing.   Taking a closer look at the Google Home setup, I realized that it was set up using my wife's Google account.   Sure enough, when I got her to test it, it worked fine with the Google Home.   It looks like the sharing for Google Home wasn't set up properly.  

thanks, I tried again via the assistant on my phone, but get the same road block.


Could you tell me exactly how you went through Assistant? When open the assistant and press the explore button, I search for Telus home assistant, and it bring brings me to a webpage that talks about it, then press setup and it brings me to "Home control" and list my devices and rooms. When I press plus, its brings me to the same route the google home does.

I solved the issue by making an optik account and logging in with that. I'm now able to control my optik boxes with GH.

Now that the Telus Home Assistant has officially luanched, I unlinked it and tried to link to the release version but I'm having a similar issue with linking. I think the problem is it does not see the optik boxes. When I link via Google Home, and then sign in and allow Telus/Google to integrate, it just goes back to the setup screen and my optik boxes do not show up. I can unlink Telus (not via the GH App, but via as described below), so it is linking. I had the same problem with Telus Assistant BETA, but the moment I signed in using my Optik account (instead of My Telus), everything worked.


With the release version, can I sign in via my Optik Credentials? I dont seem to have that option anymore.

Thanks Telus. The issue has been resolved. I'm able to link my optik boxes to GH again.

Hi. I am having the same problem you were having earlier - when I try to link Telus Home Assistant in the Google Home app a message comes up saying, ``Linking your Telus Home Assistant account...``, but instead of asking me to log into Optik TV or My Telus account it just goes back to the Google Home Setup screen.


I spent from saturday noon until 6 pm trying to get telus support to fix the problem but made no progress. Telus rep called me back sunday and gave me a number to call which turned out to be Google Home support. They said the process was aborting because the telus server wasn`t responding. They had me unplug the telus router and Google mini and optik tv box and reconnect. Internet would not come back up (no internet, tv or phone) at which point I had to call telus support again and after more than 4 hours they determined the failure was because they were trying to connect to my previous street address (of 17 years ago!). Telus picked up the old (dead) account that had the same name and phone number by mistake. I have my internet, tv and phone back and have spent 2 hours monday with telus with no luck. No person I have talked to at telus has ever seen or been trained on Telus Home Assistant let alone linked it to Google Home and used it to control an optik tv box. When I ask to speak to someone who has, I am told there is no one. 

to be honest, almost everything I've done did nothing and it eventually resolved on its own. I called Telus and Google.


At this point, I'm wondering if it even works for anyone, even after the linking issue. I'm afraid to unlink/link 


Ironically, the beta version was the most stable one!

I'm starting to wonder if the problem is with Google Home. My Honeywell smart thermostats have been going offline (not detected) lately in GH but the Honeywell app sees them just fine. Same with my WeMo light switches. Once in a while one or two switches will go offline in GH but I can see and control them with the WeMo app.

honestly, I don't know, but I know what you mean with GH being spotty. One thing I can tell is that  Telus Home Assistant is consistently not working for me, i,e, its not spotty, on or off thing. The Optik boxes show up in my GH rooms, and click on them and it says "not available", even voice-commanding it. Its been down for several weeks now for me.

Friendly Neighbour

Not sure what has changed but today I was finally able to add back in Telus home assistant to my Gh, everything is working correctly. 

hi, thanks for the message. Just unlinked and linked my account, and of course it said there was an error linking but then I noticed the boxes showing up in GH so I added them back to the rooms. Can't tell right now if it will respond because im not home. However, did the "Telus Modem" also show up as a device? It seems I cannot edit it or move it to a room.

Friendly Neighbour

Yes it did show up for me as well. I was able to assign it to a room.

interesting, so I see the Telus Modem but when I click on the wheel, I cannot edit the room or the home so its just floating at the bottom there, unassigned. Not sure if its related to the my Telus boosted network (I dont think), but at least now my Optik boxes are working via GH!


thanks for the heads up

that's interesting. I'm still not getting mine to link. It says " Couldn't update the setting. Check your connection." after I sign in with my telus credentials.

Community Manager

Hi Folks, sorry to hear that there have been setup issues with your accounts. Because this product remains in Beta, difficulties like this are to be expected. However, if you're experiencing prolonged issues with linking your accounts, then our technical support at 1-888-811-2323 will be able to send a trouble ticket to the development team. You can also chat with them online, using the "Chat" tab at the bottom of the following page.