Showing results for 
Show  only  | Search instead for 
Did you mean: 

Intermittent ipv6 connectivity after upgrading to fiber in North Vancouver


I just upgraded to fiber from DSL and got swapped to a T3200m modem as well. I am still getting an ipv6 address (real 2001:569:...)however, routing of ipv6 is no longer working. Windows responds "Destination net unreachable" when trying to ping any valid ipv6 address. I am able to ping the link local and ipv6 address of the T3200m. On the T3200m, using the ipv6 ping test page, all internet addresses are timing out as well which leads me to believe there's an issue in the core network. I've rebooted both the ONT (Nokia) and T3200m but the same problem persists.


Ipv6 was working fine on DSL, and it has intermittently worked in the 36 hours or so that I've had fiber but it seems more down than up. Is anyone else experiencing this issue? Any next troubleshooting steps?



As an update, I have spoken to our network team and there is indeed a vendor specific difference of opinion in how the RFC is handled to maintain an IPv6 default route. Without getting into specifics, the Actiontec T3200M drops the route after 90 minutes in certain areas of North Van. There is a firmware update scheduled in the next 6 months to resolve this, unfortunately I do not have a specific date.


Workaround: Replace the Actiontec T3200M with Actiontec T1200H. This will not drop the IPv6 route.

Caveat: This older Actiontec gateway has slower WIFI and uses HPNA over Ethernet, not MOCA like the current 3200M does. If you have TV services using the coax cable in your house, this solution will break the TV aspect of the service.


If this works for you and are ok with the caveats, please reach out to the support team via the chat and mention this post. We will send out a  gateway pro bono to you by mail or by technician depending on availabilities. The agent can reach out to me specifically if they need clarification. They will check the network to see if you would be impacted and advise accordingly.

Updates are pushed to the gateways either via schedule or when a factory reset is performed so without a specific date known, would recommend a manual firmware update from time to time to see if a new one has been released. 


If you have any success with this workaround, please post an update here.




View solution in original post


Still not working for me. The original issue with the T3200m persists.

Originally they had wanted me to wait for a fix on their back end but decided best thing was to try the new modem after that did not pan out, so I am not sure if they are planning on fixing the T3200M or are just taking their time (originally it was suppose to be fixed months and months ago. 


I think the best thing would be to just ask for the new modem.

Any update with the firmware update?


Currently running with ipv6 disabled; Are there any disadvantages to this approach?

EDIT: Sorry I couldn't figure out a way to edit my previous post. Is anyone even able to pass this test?

Hi there,
I've recently upgraded to Fibre in North Vancouver as well and have been noticing the same issue. I'm on the latest firmware (31.164L.18) for my router (T3200M) and can see that for the first ~90 minutes there is a valid IPv6 route however after that the route drops and I lose IPv6 connectivity resulting in intermittent slow downs/disconnects with my devices until they fallback to IPv4.

Once I knew what to look for I was able to find that a business in the same building as well as a friend a couple blocks away are also experiencing the very same issue.

@Jordan_Labelle You mention that an update would be released to the T3200M that would fix this issue. Do you have any news on that?


Unfortunately not. 

It has been confirmed the new WIFI hub works fine in maintaining the IPV6 route. This new gateway has more or less superseded the Actiontec 3200.

If you don't want to wait and need an immediate resolution, speak to our technical support teams and mention this thread. 

The technical support team will need to check the distribution layer and see the equipment that the service runs through to confirm if you are impacted. 

We have an internal understanding to have the T3200m replaced with the WIFI hub once it is confirmed.





Jumping in here too as I believe I've been having the same issue in North Delta edge router in Surrey for the past year+. My current setup that works for an hour or so:



:ballot_box_with_check:  Request only an IPv6 prefix

56  DHCPv6 Prefix Delegation size

:ballot_box_with_check:  Do not wait for a RA

:ballot_box_with_check:  Do not allow PD/Address release 



Track WAN

Both TM3200M and my own router have the same issues.


Friendly Neighbour

I'm also in Surrey and my ipv6 wasn't working so I just tried these settings and it started working again.


I have set a timer for 92 minutes from now so I can see if it works.


Pretty sad that the Telus edge router is so temperamental. Does anyone know if this is a case of the edge router not behaving according to the standards or are the standards not well defined enough?

Friendly Neighbour

Lost ipv6 after 90 min... Booooo!

Yeah it’s still broken here in North Vancouver too. I don’t expect this is going to be fixed any time soon. I’ve been trying to get Telus to fix it for a year and I think at this point if I really want IPv6 I have to use another provider.

I’m not really interested in getting a new router but would still like to be able to keep an ipv6 prefix for longer than an hour. Is a fix still planned for this issue? If not I’ll look into swapping out my T3200. (Not sure how that works right now)

It has been confirmed the new WIFI hub works fine in maintaining the IPV6 route.


Hi @Jordan_Labelle does the new WIFI hub have any caveats like you mentioned for the Actiontec T1200H in the accepted solution post?

(I'm having this ipv6 drop on T3200M with firmware 31.164L.18)

I had my T3200M replaced with the WiFi hub. So far so good. IPv6 still working after 1 day.

The only inconvenient was the size of the WiFi hub. It doesn't fit in the utility cabinet, so the installer had to mount it on the wall and gently run the fibre through the side of the cabinet door without pinching it.

I got my T3200M replace with Wifi hub as well back in May.  It did appear to fix the issue until my first power outage / modem reset.  After that, i've never been able to keep an IPV6 connection stable past 90 minutes on reboot.  I'm running my Wifi hub in Full Bridge mode and using Pfsense on bare metal.


WAN settings:

IPV4: dhcp
IPV6: dhcp6
request prefix only
/56 prefix
do not wait for ra
do not allow pd release


LAN settings:

ipv4: static
ipv6: track interface
upstream gateway: none
track ipv6 interface: WAN


Add a cron job in pfSense that runs “/sbin/rtsol -a” once every so often. (I think an hour works, and you can replace the -a with the interface name on your WAN if you don’t want to send the RS on your LAN) In my experience that keeps the route working for days, although it seems to eventually drop even with that. It would be nice if Telus could tell us exactly what’s necessary to keep things running without reverse engineering it but I don’t know who I’d even ask about this.