Intermittent ipv6 connectivity after upgrading to fiber in North Vancouver


Spent a few minutes trying it out and it didn't work. Outside of that the only issue I had was a laptop that I had connected to wifi for some reason was failing the IPV6 test while my phone was not. Once the laptop was restarted everything worked fine. Not sure if there is some other issue here but outside of that incident everything seems to be working.


Hey Jordan/all,


I can confirm the T1200 works and holds the routes past 90 minutes.  I'm just over 24 hours of continuous working IPv6, so no route dropping here, in Surrey.


I have a bit of a unique setup that I won't mention here in order to keep this from getting complicated, but the T1200 works very well for IPv6, and with some modification to the IPv6 firewall rules that are on the router, I was able to get a 20/20 score, consistently, on  Before modifying the FW rules, I was getting 18/20.


Now, hopefully soon, both the Juniper RE's and T3200 firmwares are released and updated on the TELUS side so that we don't need these workarounds 😉 .


Let me know if you have any questions.



TELUS Employee
TELUS Employee

Perfect, thanks for the update. I will share this with our network teams internally.





Friendly Neighbour

Any updates on this issue?  Still doesn't appear to be a firmware update.  

If could be upto six months wait so around June.

Any update on this? IPv6 still seems to be broken in my area of North Vancouver.

Friendly Neighbour

I live in Surrey and have the same issues described here, i.e. ipv6 not working after 30-90 minutes after reboot. It's now nearly Oct 2019. Any update on a fix for this ipv6 issue?




So not sure about Surrey but in North Vancouver apparently the issue was due to a combination of some back end hardware and the ActionTek t3200m.


With the older modem there was no issue but this was a work around as it has weaker WiFi and also some incompatibility with the TV that required additional hardware.


With that said the problem was not resolved as of a few weeks ago so I followed up with the support rep I had been talking to and he went ahead and scheduled a swap of the modem to a newer modem that apparently isn't available everywhere. Not sure what its called although the rep that swapped it out called it a Diaper Genie as that's what it looks like lol. Long story short I have not had issues since the swap.


Maybe get support to upgrade your modem?


See my reply to the post below this.


Hi there,
I've recently upgraded to Fibre in North Vancouver as well and have been noticing the same issue. I'm on the latest firmware (31.164L.18) for my router (T3200M) and can see that for the first ~90 minutes there is a valid IPv6 route however after that the route drops and I lose IPv6 connectivity resulting in intermittent slow downs/disconnects with my devices until they fallback to IPv4.

Once I knew what to look for I was able to find that a business in the same building as well as a friend a couple blocks away are also experiencing the very same issue.

@Jordan_Labelle You mention that an update would be released to the T3200M that would fix this issue. Do you have any news on that?


TELUS Employee
TELUS Employee

Unfortunately not. 

It has been confirmed the new WIFI hub works fine in maintaining the IPV6 route. This new gateway has more or less superseded the Actiontec 3200.

If you don't want to wait and need an immediate resolution, speak to our technical support teams and mention this thread. 

The technical support team will need to check the distribution layer and see the equipment that the service runs through to confirm if you are impacted. 

We have an internal understanding to have the T3200m replaced with the WIFI hub once it is confirmed.






Jumping in here too as I believe I've been having the same issue in North Delta edge router in Surrey for the past year+. My current setup that works for an hour or so:



☑️  Request only an IPv6 prefix

56  DHCPv6 Prefix Delegation size

☑️  Do not wait for a RA

☑️  Do not allow PD/Address release 



Track WAN

Both TM3200M and my own router have the same issues.


I’m not really interested in getting a new router but would still like to be able to keep an ipv6 prefix for longer than an hour. Is a fix still planned for this issue? If not I’ll look into swapping out my T3200. (Not sure how that works right now)

jag_rana, thanks for information.


Although it was working for the longest time looks like there is a new problem, maybe its just local to me. Once I switched over to the new router everything was fine but now it seems the router does not get a IPV6 address at all. All of my devices have a local IPV6 address but the router itself does not. 

I confirmed using, ipv6test and looking at the routers network connection page which showed only a IPV4 address. I have tried reseting the router and power cycling the ONT and the router. No luck.

@Jordan_Labelle any idea if there is a new issue? Hopefully this can get resolved soon.


Looks like its working again. I really wish Telus would be more consistent with its IPV6 implementation. Seems to be a after thought at the moment.

Still not working for me. The original issue with the T3200m persists.

Originally they had wanted me to wait for a fix on their back end but decided best thing was to try the new modem after that did not pan out, so I am not sure if they are planning on fixing the T3200M or are just taking their time (originally it was suppose to be fixed months and months ago. 


I think the best thing would be to just ask for the new modem.


Any update with the firmware update?


Currently running with ipv6 disabled; Are there any disadvantages to this approach?


EDIT: Sorry I couldn't figure out a way to edit my previous post. Is anyone even able to pass this test?

Friendly Neighbour

I'm also in Surrey and my ipv6 wasn't working so I just tried these settings and it started working again.


I have set a timer for 92 minutes from now so I can see if it works.


Pretty sad that the Telus edge router is so temperamental. Does anyone know if this is a case of the edge router not behaving according to the standards or are the standards not well defined enough?

Friendly Neighbour

Lost ipv6 after 90 min... Booooo!

Yeah it’s still broken here in North Vancouver too. I don’t expect this is going to be fixed any time soon. I’ve been trying to get Telus to fix it for a year and I think at this point if I really want IPv6 I have to use another provider.

It has been confirmed the new WIFI hub works fine in maintaining the IPV6 route.


Hi @Jordan_Labelle does the new WIFI hub have any caveats like you mentioned for the Actiontec T1200H in the accepted solution post?

(I'm having this ipv6 drop on T3200M with firmware 31.164L.18)


I had my T3200M replaced with the WiFi hub. So far so good. IPv6 still working after 1 day.

The only inconvenient was the size of the WiFi hub. It doesn't fit in the utility cabinet, so the installer had to mount it on the wall and gently run the fibre through the side of the cabinet door without pinching it.


I got my T3200M replace with Wifi hub as well back in May.  It did appear to fix the issue until my first power outage / modem reset.  After that, i've never been able to keep an IPV6 connection stable past 90 minutes on reboot.  I'm running my Wifi hub in Full Bridge mode and using Pfsense on bare metal.


WAN settings:

IPV4: dhcp
IPV6: dhcp6
request prefix only
/56 prefix
do not wait for ra
do not allow pd release


LAN settings:

ipv4: static
ipv6: track interface
upstream gateway: none
track ipv6 interface: WAN


Add a cron job in pfSense that runs “/sbin/rtsol -a” once every so often. (I think an hour works, and you can replace the -a with the interface name on your WAN if you don’t want to send the RS on your LAN) In my experience that keeps the route working for days, although it seems to eventually drop even with that. It would be nice if Telus could tell us exactly what’s necessary to keep things running without reverse engineering it but I don’t know who I’d even ask about this.