Showing results for 
Show  only  | Search instead for 
Did you mean: 

Crave TV

Just Moved In
I have PIK TV, an Apple TV box and crave. Recently crave has started telling me I need a subscription before watching anything. I have tried resetting the Apple TV, logged out and back into crave and normally it would work. But now it does nothing. It’s been 2 days and I can’t watch anything on crave. I have tried logging in via service provider (Telus) and nothing. I can get into the app and see all the shows, I just can watch anything...

TELUS Employee
TELUS Employee

Hi @CL12 


What happens when you navigate to Crave via the On Demand menu of Pik TV? On your Apple TV, open the Pik TV app, navigate to On Demand --> Channels --> Crave. If you can watch here, then it's likely a link problem with Bell. If you can't watch here, then it's TELUS.


It's also worth noting that there are two 'versions' of Crave: Crave ($10) and Crave + Movies + HBO ($20). The $10 version has more limited content, so if you're trying to watch a recent HBO series, you might get a prompt asking for a subscription. There's an overview of Crave packages here: