Oplik TV service

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Resident
Why is there a black screen on all the channels on the Oplik TV service and not any pictures on screen?
Community Power User
Community Power User

Not my experience. Can you provide more details of your situation?

 

Have you tried resetting the PVR by unplugging it for a few seconds, or pressing the power button for about 15 seconds?

 

NFtoBC
If you find a post useful, please give the author a "Like"
Friendly Neighbour

Same experience here. Reset a lot of times but nothing! The message was Optik TV is initializing. Left if for a long time until the next day nothing happened. The message on initialization's still there. A week before that the pictures on tv were pixelated and on and off. I thought my TV was the problem but I tried my Apple TV and it's working without any problem at all except that the signal for 2.4g and 5g are not working anymore. I can still see the 2.4g and 5g wifi signals but there are no internet connections. Called support but quit in frustration because of the long wait which Telus is famous for. Tweeted support and gave me a number which will be the same experience again for the long wait. Got an e-mail to Support support who will diagnose my connection remotely but how can I get Support without calling and endure the long wait! Until now I still don't have my Optik TV and the lost 2.4g and 5g wifis for over two weeks now. Paying for the service that is not even there! Wake up Telus! Support should be as aggressive as your sales/marketing. You don't ignore customers once they become subscribers!