cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Galaxy S6 Edge does not work with Optik on the go

Upcraft
Ambassador

According to the Optik on the go app on my Telus Galaxy S6 I am not in Canada.


That is what it says no matter what channel I try to stream in the app.  Does not matter if I am on WiFi on the home Actiontec router, LTE, or some other Wifi network.  This is all it ever says.


Location services are enabled.  GPS locks to my location in Google maps and any other third party application immediately.  I have the app GPS Test plus. It shows my coordinates and connected GPS satellites are all working perfectly.

If I go into application manager in the settings I can see in App info that the application has full approximate (network based) and precise location (GPS based) permissions.  




1 ACCEPTED SOLUTION

Upcraft
Ambassador

Thanks for letting me know it works for someone.  That helps.  I can dig deeper on troubleshooting without worrying that Telus just has not added some required support for this model.


No VPN. The screenshot would show a padlock icon in the top if VPN were active. Other android devices here on the same network work properly with the app on the same account.  I just tried installing a VPN and connecting to a server in Vancouver, same result, no change.


Tried rebooting

I tried clearing data and cache on the app

I tried uninstalling it and reinstalling.

Running the new July 17 kernel version that was recently pushed to fix that Stagefright security bug, but had the issue before that update too. 


The smart remote app works like it should.


EDIT:

I found it.  I had developer options enabled.  I did NOT have mock locations selected in the UI but I think it might have been enabled at a lower level and the settings UI just wasn't showing it (have seen that happen in android before when low level features were running without UI showing them enabled).  Toggling mock locations on and then off again and now I can leave developer options turned on and it works.  Possibly the setting was active internally as a result of restoring my account settings from previous device when I first setup the phone.  I was doing some hacking around with my older phone at the time when I got the new one.  

If I turn on mock locations I get the same error I was seeing before (This time the UI in settings actually shows it's checked though being the big difference)


So solution is.  Turn off Settings->developer options. Toggle mock locations on and off again to make sure any low level debugging/developer features are disabled properly.  Can probably just leave developer options off entirely until it's needed.  I will do my messing around with older hardware I no longer care about anyhow.


View solution in original post

4 REPLIES 4

NFtoBC
Community Power User
Community Power User

Just added it to my S6edge; works as expected. Are you using a VPN, by any chance?

NFtoBC
If you find a post useful, please give the author a "Like"

Upcraft
Ambassador

Thanks for letting me know it works for someone.  That helps.  I can dig deeper on troubleshooting without worrying that Telus just has not added some required support for this model.


No VPN. The screenshot would show a padlock icon in the top if VPN were active. Other android devices here on the same network work properly with the app on the same account.  I just tried installing a VPN and connecting to a server in Vancouver, same result, no change.


Tried rebooting

I tried clearing data and cache on the app

I tried uninstalling it and reinstalling.

Running the new July 17 kernel version that was recently pushed to fix that Stagefright security bug, but had the issue before that update too. 


The smart remote app works like it should.


EDIT:

I found it.  I had developer options enabled.  I did NOT have mock locations selected in the UI but I think it might have been enabled at a lower level and the settings UI just wasn't showing it (have seen that happen in android before when low level features were running without UI showing them enabled).  Toggling mock locations on and then off again and now I can leave developer options turned on and it works.  Possibly the setting was active internally as a result of restoring my account settings from previous device when I first setup the phone.  I was doing some hacking around with my older phone at the time when I got the new one.  

If I turn on mock locations I get the same error I was seeing before (This time the UI in settings actually shows it's checked though being the big difference)


So solution is.  Turn off Settings->developer options. Toggle mock locations on and off again to make sure any low level debugging/developer features are disabled properly.  Can probably just leave developer options off entirely until it's needed.  I will do my messing around with older hardware I no longer care about anyhow.


View solution in original post

NFtoBC
Community Power User
Community Power User

I'm running the same kernel, if that helps.


EDIT: Thanks for sharing your solution / resolution. I hope you keep coming back to offer solutions to others.



NFtoBC
If you find a post useful, please give the author a "Like"

Upcraft
Ambassador

Yep.  I just edited my reply.  Found the problem.  Developer options mock locations apparently was active even with the UI showed it was disabled.  

Solution is disable developer options or toggle mock locations on and off again to clear the inconsistency.