cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Geo Fence Problem

Robert_746
Organizer

I’ve had Telus SmartHome for a few weeks now, and I just cannot get the Geo Fence feature to work properly. I want a notification when motion is detected and I’m not home. So, I’ve set up a notification and selected the geo fence option (I selected my geo device which is my phone, and I selected my geo fence). This does not work. I get motion notifications whether I’m home or not.

 

(Oddly enough, my geo fence does seem to be working for my exterior Video Camera. I want notifications (and video recording) only when I’m away, and I have that set up and it seems to be working fine. So it is only my Doorbell that has the problem).

 

I’ve contacted Support several times and, while they are helpful, my confidence in the SmartHome service is a little shaky. (Unfortunately I missed the end of the 30 day trial period—I would like to cancel but it’s too late for that).


Has anyone had a similar problem and we’re you able to resolve it? Please help.

9 REPLIES 9

NFtoBC
Community Power User
Community Power User

Is the system armed, or are you simply depending on the geofence?

 

NFtoBC
If you find a post useful, please give the author a "Kudo"

I don't know what you mean by "arming". I just have the cameras, and the filtering options available are: geofence, and time blocks (i.e. all day or at a specific part of the day). I'm relying on the geofence.

Thank you for your reply. Is there anything else I can do to try to resolve this problem?

Did you ever find a solution to your problem? I am having a similar issue and I am about ready throw the camera out my balcony window I am so frustrated

My system seems to be working now, but I don’t really know what “fixed” it. Over the past year, here are a couple of things I’ve learned:

  1. Theory: The Geo-Fence does not work right away, it seems you have to enter and exit the defined area before the system finally calibrates and then the notification filters seem to work.
  2. Troubleshooting: The other thing I tried a few times was to completely reset the security devices and start out with no notifications whatsoever. Then gradually enable individual notification options one at a time. Test with that setting for awhile until your are confident it is working. Keep doing that until you are starting to get more notifications than you want, then undo the last change you made.

Sorry, I wish I had kept detailed notes about what I did. Ultimately, I really do not like the Smart Home Security website or apps. They are incredibly confusing. This product is  disappointing. I regret signing up on a 3-year contract. I just thought “it will just work” when I signed up — big mistake.

[Sorry for not replying sooner]

Roda
Just Moved In

Mine just started doing the same thing was working for a few months but now just videos everything inside and outside of  the geo fence and when I am home even though that is set as an exception. I deleted the video settings and started over but did not fix the problem. 

Sorry about that! We recommend reaching out directly to our SmartHome Security team at 

1-855-255-8828 so they can troubleshoot further with you!

Robert_746
Organizer

I found an important setting to check.

 

This problem started happening to me again. I recently deleted and reinstalled SmartHome app (to troubleshoot another problem), and lo and behold, the unfiltered notifications returned. Getting notifications when I’m at home. (The only notification I don’t want to be filtered is for the doorbell call button).

 

From the main menu I selected Manage Devices, I opened the settings for my iPhone. I noticed that Location Sharing said Disabled. What?! I then opened Places from the main menu. At the bottom of this screen I tapped Manage my location settings. I toggled Location Services to on (it was off!). My phone asked if I wanted to allow SmartHome to share my location. It asked me to choose Never or When Using The App (I forget exactly). I chose While Using App. But this didn’t seem sufficient to me, so I went into Settings > Privacy & Security and for the SmartHome app I selected Always. There is indeed a note there saying that choosing Always is recommended for location-based rules and notifications to work properly.

 

So my location-based notifications seem to working properly now. I’m not being bombarded by notifications at home, at least. (I did get a few and then none after awhile. Maybe it took awhile for the location setting to take effect). The real test will be the next time I am away from home, will I get those notifications, as those are the ones I really want? I’m confident I will. If not I will update this thread.

 

I hope this helps someone. It frustrates me that the app never prompted me to enable location sharing when I originally set up the location-based rules and geo-fence. And I mean a prominent pop-up prompt, like what you get with any other app that asks to access your device’s location.

MadMutant
Just Moved In

I'm running a Samsung Galaxy S10 and installed the SmartHome app about two weeks ago. I have two indoor cameras set up. Everything was working fine until yesterday. The geofence portion isn't recognizing the location of my phone anymore and everytime I go from one room to another the alarms on the camera go off.

System info is as follows:
Android 12
Location services set to precise

Battery optimization is off
Geofence is set to the minimum which is 1.5 km
I can't go from one room to the other without setting off the alarms and having a dozen videos of every trek to the bathroom.