Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pik TV Apple TV app shows freezing


I noticed recently that frequently shows no matter the channel will freeze video but not audio when playing then the show speeds the video up to catch up to the audio so as to be in sync. Each time this has happened I’ve run app on my Apple TV where I’m using the Pik TV app and on my iPhone. Both show up and down speeds approximating 700 Mbps on my gigabit fibre connection. Has anyone else experienced this lately? 


Good Samaritan

We have the same issue...have been on the phone to Telus Tech support three times in the last three days.  They steered me into upgrading my internet from 25 to 75 but after testing the problem persisits.  Video will freeze while audio plays on and then the video will speed up as though the person speaking is speaking very quickly to catch up.  Net result, three days of frustration and sold a higher internet feed not needed.

We have been getting a lot of errors messages prior to this..."using multiple copies, close one" etc...

Good Samaritan

been on the phone with Telus Tech today, Saturday, and it appears the issue is with the Apple TV ... told they are looking into this now.

Based on none of the streaming apps Prime, Netflix, YouTube or Disney+ display this issue with the exception the Pik TV app then it would seem to be a developer issue which is Telus, not Apple. As mentioned this is not a bandwidth / speed issue as I have a gigabit fibre connection with over 700Mbps up/down and the only other devices connected to the network while running the Apple TV is my son’s iPad and our iPhones. Hopefully Telus can resolve this bug soon.

Completely agree….we have Prime, Netflix,   All working flawlessly but, apparently Telus has some difficulty seeing this issue.  As mentioned been on the phone four days in a row and the only effort to date by Telus Tech support was to upsell my Ethernet.

PIK is a “not ready for prime time app” so hoping they solve this one.  One tech talked about “congestion” on our network….?

Community Power User
Community Power User

@KHRCan you look into this.

Thanks, Warren

Problem started again, this morning...our local Power User, above, appears too think this is a new issue.....this has been a problem for some time...

And why the need to ask for "likes"...not getting too many in your day job?

Same issue here. Was happening a few months ago, then it was fixed for a while and now it’s back.

Hey, I've been censured by the moderator for my recent comments so suspect I am in trouble...seems our very darling local resident Power Users have been offended by my comments...

I have no objection to guys that hang around a site continually but it must be expected that they have more to offer than simple  some people have had these issues so just our lovely local power users (how and why are you power users?)  .if you are just hanging around, please know something more about this issue than simply reducing to...just search...etc

This issue with PIKs in a recurring software problem...happily I have been able to correct my two incidences, one in March of this year and then just recently but suspect it will reappear, so suggest you look at your network connections...reboot your network, check the DNS settings, etc...but realize that Telus has no interest in solving this are on your own...this site is useless for anything to do with customer service.

So, long til this is toast

Looks like switching the DNS provider on your AppleTV will solve the issue.


As soon as I put in the OpenDNS server entry things were stable again.


October 19th, trying to watch the Oiler game and Pik tv keeps freezing for 5 seconds, sound continues, then the picture catches up to the sound.  Very frustrating!!

Pik tv app version 1.6.1 on Apple TV 



I had the same exact problem with the Optik TV app on my Apple TV 4k. At first, it was via a wi-fi link and then I moved to a Cat 5E wired link with the same result.  Telus support told me it was because I was using another router and port bridging on the T3200M Telus modem.   So my solution was to remove the port bridging and connect my Apple TV 4k directly to a T3200M gigabit wired port. My Optik TV 4K decoder is also in a port on the T3200M modem. The only problem I have now is pixelization and picture freeze.  I scaled down the aspect ratio from 4k to 1080P, this has slightly improved but not solved completely the problem. I still use my other router for WI-fi which I have disabled on the Telus T3200M modem.  My ASUS router is also directly connect to the T3200M modem just like my Apple TV 4k and Optik TV Decoder.  The Telus T3200M WI-fi does not support wi-fi 6 high speed and WPA3 security which is the main reason for  my ASUS router. My Mac's WI-fi does support both of these features. I alos had to modify the subnet mask on the T3200M so both my wired and wi-fi networks could connect.


let me add that connecting my Apple TV 4k directly in a gigabit port on the Telus T3200m has solved this freeze problem on the Optik TV app which is basicallly the same as the Pik TV app.