Guide/Channel Changing Extremely Slow

Reply
Highlighted
Roteco
Connector

Using the guide, and changing channels, on the main Optik TV box has become incredibly slow. Just started in the last month, but if I try to use the guide to surf what's on, or scroll through so I can set up a recording, it seems like the things slow right down on the set top box. It used to be really quick when I would move through the guide, but not so anymore. When I page up/down when using the guide, it takes about 5 seconds for the channels shown to change on the screen. And if I press the up/down button too quickly, the picture of the channel I'm currently on freezes, or the whole screen flashes black for a second. If I'm searching for something to watch, it takes about 4-5 times longer to do it than it did about a month ago. Also, whatever the issue is, it seems to have affected the previous channels option as well. If I press Prev on the remote, it takes about 15 seconds for the previous 5 channels viewed to come up on screen. And when they do, it doesn't always show the picture associated with the program in the little box - just the green outline with the title below. This also used to be a very quick feature, but is not anymore. I thought that maybe I had too many programs PVR'd, and it was clogging things up, but I cleared the PVR storage and nothing has changed. Is there an update option I can use to fix this? Was there an update done that caused this? I'm looking for solutions because this is extremely annoying for a piece of equipment that's not even 2 years old yet. FWIW, I have two secondary boxes for TVs in other rooms, and they still work just as they always have. Still quick as ever. It's just the main box.

Community Power User
Community Power User

My PVR started doing that recently and a reboot of the box seemed to speed it up.

Community Power User
Community Power User
I reboot all my telus devices once a month to keeps things running smooth. It only takes a few min for everything to cycle for "online" status. The older Optik tv boxes had less memory and slowed down over time vs the newer hardware Telus now uses.

Most Helpful
Skiddy
Coach

Just fixed mine last night. It was getting dial-up slow and extremely frustrating. Channel changes, PVR skips etc...

Unplugged it last night and plugged it in this morning, gave it about 1/2 hour to do its thing then started it up with the remote and it was back to that fantastic experience when it was first installed. I guess like most things and people, it just needs a good kick once in awhile. 

 

(The other boxes did not seem affected, just the 7150 PVR)

Roteco
Connector

Unplugged it a noon today, and just plugged it back in about 4 hours later, and it seems like it's back to normal operating speed. Thanks to all for the help!