Showing results for 
Show  only  | Search instead for 
Did you mean: 

telus webmail


Hi i have not been able to log into Telus webmail since Sept 26 , i will either get password error or 

 A network service error has occurred. When i tried to contact the 24/7 virtual assistant tonight but i get the message that they are closed lol.

Anyone else with this problem? I am in Victoria bc.


Community Power User
Community Power User

Yes. See


However, webmail is working for me this morning. Have you tried restarting your browser?

If you find a post useful, please give the author a "Kudo"

Yes i have tried on 2 different computers as well as 2 different mobile devices .

Community Power User
Community Power User
Clear all internet history and cache. Tested webmail on my desktop browser and mobile. Signed in without issue.

Manually type in your user name and password and see what happens.

Thanks for the help everyone , finally got through to telus again , yesterday the tech didnt know what the problem was and just gave me a temp password that did not work and told me to try again later ,but today the person figured it out , apparently when they switched me to fiber a couple of weeks ago the email wasn't switched so it stopped working 3 days ago , everything has now been fixed , thanks again.