email - Windows 10 - outlook 365 - Invalid certificate

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Neighbour

past few days receiving error msg

"server you are connected to is using a security certificate that cannot be verified etc"

Have "viewed certificate" and installed it but after closing Outlook and re-launching, same error msg.

Anybody else?

Highlighted
Community Power User
Community Power User

Have you reviewed the information contained in these support articles?  Make sure the ports, and the SSL settings are correct for your setup.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
TELUS Employee
TELUS Employee

@fdb Hey! I've been seeing this more and more lately. You need to go into your email settings of outlook and change your outgoing port servers. Follow the link @NFtoBC shared. It should all be in there. If you still have issues, you can reach 310-TECH or Tech Support Plus at 1-855-575-5705.

 

Good luck!

Highlighted
Neighbour

Reviewed them and changed accordingly. Did not help. I used the Outlook 2016 tab which is the closest to my Windows 10 Office 365 Outlook i guess.

Upon setup a yr ago - Telus support wouldn't help - said call Microsoft. That config was

[server information]

Account type = IMAP

"incoming" = mail.telus.net

"outgoing" = smtp.telus.net

[more settings]

"my outgoing server (STMP) requires authent ...." = checked YES

"use same settings as my incoming mail server"  = checked YES

[advanced]

"incoming server" = 143   // "encrypted connection" = STARTTLS

"outgoing server" = 587  // "encrypted connection" = STARTTLS

 

Talked to Telus Support - what finally worked was / only changes made

[advanced]

"incoming server" = 143   // "encrypted connection" = NONE

"outgoing server" = 25  // "encrypted connection" = NONE

 

Is this the config i want to use forever?

Or is this just a workaround?

 

I started getting the "invalid certificate" msg about 10 days ago. The 1st time, i installed the certificate and it worked for a couple of days (even thou the dates were screwy). Telus changed the certificate to contain valid dates but installing it wouldn't solve the problem, every Outlook launch would get the error again.

Highlighted
Neighbour

thanks for the "good luck" hologram123

that helps a fricken lot.

Highlighted
Community Power User
Community Power User

Use of SSL/TLS as the secure authentication path should work with the ports you listed with STARTTLS, though 993 / 465 would be better.
The unsecured connections will likely only work when connected to Telus’ network, so if you take your device elsewhere, you may not be able to connect.

NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
Neighbour

Thanks NFtoBC. The problem seems to be fixed.

While i was waiting on hold for telus support, i re-read the support documents you suggested and tried the parameters from Windows 10 and then Outlook 2016 and then Outlook 2013. i have MS Office 365's Outlook. i fixed it just as telus got to me.

My config now is

[server information]

"incoming mail server" imap.telus.net

[server port numbers]

"incoming server" 993 / "encrypted connection" SSL/TLS

"outgoing server" 465 / "encrypted connection" SSL/TLS

 

Highlighted
Community Power User
Community Power User

@fdb 

   Happy to learn you got it sorted. If you look at all the different instructions for the different mail clients, it is not always clear when to use SSL and not. There has also been recent confusion of mail clients automatically provisioning STARTTLS rather then the SSL/TSL Telus uses.

 

 

Re: "I started getting the "invalid certificate" msg about 10 days ago." 

I wonder if an update was pushed to the mail client switching authentication to STARTTLS? Thunderbird clients had a similar problem.

 

NFtoBC
If you find a post useful, please give the author a "Like"