Showing results for 
Show  only  | Search instead for 
Did you mean: 

New Register device pop-up, no internet

Just Moved In
My internet was working fine yesterday. Got home last night and suddenly all. My devices want me to sign in. If I follow the link it tries to bring me to which fails to load.

This is happening on my phone, desktop and laptop. I tried plugging my laptop directly into the modem. It still does this.

I tried unplugging the modem and factory resetting it. Nada.

I can get to the modem configuration on my laptop and tried resetting everything under the sun. It didn't help. I checked parental controls all is good.

Under status it says LCP and IPCP are down .... Which is, not good. Can't think if anything else I can try.

Community Power User
Community Power User

Call Telus. Don't bother resetting things on your end, it won't fix this issue.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks. Thought this might be a telus issue (was hoping for something solvable). Guess I gotta wait for my roommate to get home... Internet is in her name.