Gateway discriminates against gaming consoles?


This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.


In all my years of IT weirdness, this one really is screwing with my head.

Have a Telus branded Actiontec T3200M Gateway with my entire network setup with wired ethernet wherever possible. (Only thing to use wifi in my house is cell phones / tablets). For whatever reason, the gateway will not DHCP assign IP addresses to any of the 4 gaming consoles in the house (Two Xbox One Xs, two PS4 Pros). Everything else that is on the wired network is working just fine, including two Windows desktop PCs, two Smart TVs with web apps, and all the wireless gadgets are working fine as well. This issue has just popped up for the first time tonight (Dec 22nd, 2018) with zero changes to my network in the slightest, everything having worked for years now.

- On either the Xbox One or PS4, attempting to set automatic wired IP configurations results in a 10.x.x.x IP being spat back and zero connectivity.
- I factory reset the gateway twice and left it unplugged for a good 2 minutes between refreshes. It is running the latest pushed firmware 31.164L.18 as of Dec 10th
- All other devices on my network are working 100%, with the T3200M DHCP server assigning IPs properly. Double checked after a factory reset, and there are no manually configured settings at all (static DHCP assigning, custom DNS servers, mac filtering, etc etc).
- Manually configuring IP settings on the consoles bypasses the issue; picked an unused unique IP from the pool for each console
- The game consoles are plugged into the same wired network switch the computers are, there is no other chain links in the networking hardware to fail.

Had several theories I was trying including the IPv6 network being down, so tried disabling it on the gateway to no luck. Changed the gatway's DNS servers for both IPv4 and 6 to Cloudflare's, no luck either. The problem is literally the gateway's refusal to assign IPs to the game consoles via DHCP, and the game consoles alone.

Any ideas?


Well the gateway started behaving after 48 hours - turns out it was identifying consoles as STB's. I plugged my old PS3 in, and I caught an automatic DHCP reservation entry for the PS3 MAC - Telus gateway thought it was an Optic TV box. Thankfully the nonsense has ended now.