Changing to a T3200M modem problems logging into modem

Reply
Resident

I received a new T3200M modem yesterday. It installed correctly and both the Ethernet and Wifi were working with the default settings.

 

I wanted to change it, but it wouldn't let me log in as admin. I phoned tech support and together we did all the same stuff that I did myself, with the same result. When we switched from Google Chrome browser to Fifrefox, we finally wer able to log in and make the changes I wanted to make (change SSID and Wifi password).

 

I'm pretty sure the issue is that Chrome requires the https protocol, while Firefox can still use the http protocol.

 

 
Highlighted
TELUS Employee
TELUS Employee

Hi Oldgeek,

 

Sorry you had to go through that experience and glad you were able to change your SSID with our agent.

One thing you can try is downloading the My Wi-Fi app. If you have a T3200M modem, you can log into to the app with your My TELUS credential and you can edit your SSID/password as well as your guest SSID!

 

Hope this helps!

 

Tony

A TELUS Employee

Highlighted
Helpful Neighbour

I can confirm I'm having the exact same issue with my T3200M Modem and Google Chrome. (July 30th 2020)

 

As soon as I switched to Firefox I had no issues with logging into the modem, but try as I might via Google it just came up with an 'Error 404' page after entering the Username/Password.

 

Chrome worked as recently as last week for me to access the modem, so some update to Chrome or the Modems firmware has broken access in Chrome.

 

I'm leaning towards Chrome being at fault as I have more and more issues this past 6 months or so accessing all sorts of websites via chrome, let alone it being slow as a snail sometimes. Where as Firefox, Opera and even old IE run faster and more reliably now.

 

Maybe the T3200M has some flash element in it's admin page as Chrome is phasing out support for Flash come the end of the year but I swear it already has as again, Firefox works for old website I have bookmarked that still run flash, where Chrome won't load these same pages even with 'flash' set to be allowed in Chrome.