cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

**FIXED** Silverlight Problem on Safari & Mac - Optic On The Go

WestCoastD
Just Moved In

It seems that a handful of users are having a problem getting Optic On The Go working using Safari on a Mac.

 

The problem I was having was that every time I went to watch a channel, I would get the message that I needed Silverlight even though I had already it installed. After many attempts I finally found the solution that continues to work for me. I am on the latest MacOS Sierra.

 

--------------

 

If you already have Silverlight installed - Open Safari and Navigate to the Optik On The Go website. https://onthego.telus.com

 

Log into your account and attempt to watch any channel, you will get the same error.

 

Then, in the main menu bar, go to the "Safari" dropdown menu and select - "Preferences"

 

The choose "Security"

 

Beside "Internet Plug-ins" - click the button "Plug-in Settings"

 

Find and highlight "Silverlight"

 

On the right you will see "Currently Open Websites". Beside onthego.telus.com change the dropdown option to "On"

 

Click "Done" and you should be good to go.

 

It worked of me, I hope that works for you all as well.

 

6 REPLIES 6

NFtoBC
Community Power User
Community Power User

I noticed that check box while dealing with a javascript & Flash error, but had not yet followed up on it. Thanks for sharing your solution!

 

I'm off  to deal with it myself, following your instructions!

EDIT: OK that took less than 2 minutes!  Thanks again for sharing your solution!

 

 

 

NFtoBC
If you find a post useful, please give the author a "Like"

scrndoor
Neighbour

Hi WestCoastID,

 

I have followed your instructions to a T!! When I tried again all I got was a twirly dot circle and then a black screen.

 

What do you think, or what am I doing wrong? I also have Sierra on both laptop and my desktop computers and they both respond the same.

 

Cheers

NFtoBC
Community Power User
Community Power User

It took quite a while for the video to start on my machine. Also make sure you have the most recent Silverlight version.

 

EDIT: Though it worked yesterday, it seems not to work today!

 

NFtoBC
If you find a post useful, please give the author a "Like"

hfmvdl
Just Moved In

No, this is not "fixed" - at least for me.  The Plug-in Setting was on "ask", so I changed it to "on". Still does not work.

Telus needs to fix this with Silverlight.  Something is just plain wedged.

 

WestCoasterBC
Community Power User
Community Power User
Many discussions on Optik on the go with the “silverlight” plugin. It’s pretty much abandoned at this point.

Telus hasn’t divulged their plans for it moving forward. But there will have to be a platform switch sooner or later to make it compatible with Mac/PC again.

So far Safari has not been cooperating following the above steps. I had the same issue when testing with my windows pc with silverlight. That was solved by downloading a version of firefox 52 that still supported silverlight. This solution worked fine for windows, but hasn't worked yet for mac. I've seen solutions suggest getting 32 bit silverlight. Going to test that out for the older version of firefox and then return with results