Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Longer Able to Log Into Website

Friendly Neighbour

I received information explaining how to transition myTelus from myADT (as part of Telus updates to SmartHome Security). Today I set up myTelus with my new account information (and a new password). I can still use the apps on iPhone and iPad (I had not logged out from these Apps prior to the transition), but on my laptop, I can no longer log into the website for viewing my system status, etc. I recognize that I can get to a similar page ( I tried to request password help information from the site (forgot username/password), but was not successful. I received an email back with my username, but the link in that email to login goes to Telus tech support said I should still be able to log into but was not able to help. Has anyone else doing this transition run into this? Were you able to resolve this and get into afterward?  


Community Power User
Community Power User

Yes, I have recently found login through does not recognize my credentials, but login through MyTelus works fine. My spouse can login directly through the Alarm.Com App, using her personal credentials. Since she is not a Telus Customer, I expect you & I need go through our Telus Credentials, as thy have set a Single Sign-On identity for us.


If you find a post useful, please give the author a "Kudo"

Thanks. I spoke again with Tech Support. They are looking into it. They felt I should still be able to log into Until this is sorted out, I will not log out of the app on my various devices. I have Siri Shortcuts activated through them etc. It would be a shame if I could not log-in again if needed.  Update will follow when I hear back from Telus.

Hi, I’ve just gone through the same scenario… except that there is no second account for me to log into It’s evening here so I’m hooped to get info… so much for an easy transition. I guess I’ll call tomorrow. If Telus wants payment, I hope they figure this out… 


Having similar issues:

- Web page login at no longer accepts my credentials

- Web page login on the Telus security migration page does not accept my credentials

- Telus Security web page "forgot password" request does not generate a forgot password message to my Telus eMail account

- Attempts to change the password on the / Telus cellphone app results in the error message "You do not have permission for this action"

Decided to ignore the migration page method:

- created a new Telus account using the eMail address registered with . This method was successful in creating a Telus security account.

- attempts to change the account verification notification to my eMail address failed

- logged out of the / telus security smartphone app .. and tried logging back in .. resuted in a "server error" message.


Apologies for the multiple postings .. here's what worked for me:

- earlier today received an unsolicited eMail from Telus Security with my new account number and my new PIN number

- created a new Telus Security account on the main Telus login web page using the same eMail address that received the Telus Security notification and using the PIN number provided.

- Created a new password for the new Telus Security account.

- deleted the app on my cell phone

- downloaded and installed the Telus Security app from the smart phone app store.

- logged in to the Telus Security smartphone app using the newly created Telus Security ID and password.

- Once that was done ... subsequent log ins to the Telus Security web page brought up a web page similar (if not identical) to the old web page.

Glad it all worked out for you in the transition @HSL .  Similar to you, after the transition, I am fully able to access my new account via the Telus Smart Home apps and website. But the email and regular mail instructions on the transition tell us that we should be able to continue using the older processes even after transition should we wish to do so. I recognize that the website and sites have a very similar look and feel, and that the Telus Smart Home Apps look, for the most part, like the apps. (Separately, I reported that the Telus Smart Home iPad app has a bug. If you minimize it and bring it back up, it will lose the menu bar on the left and the purple header area on the top, and you cannot do anything beyond that current screen until you close the app and re-open it.). Before I went too too far, I wanted to keep on working with / testing the new Telus Smart Home Apps and the website, while still retaining the rock-solid website/apps as a back-up. (Except for the one point above re the iPad app, all else seems to be working fine, including Siri Shortcuts, etc with the Telus Smart Home App, and on the website, so that is good.)
From what people have reported here and in other postings, it seems that after the transition, we, in fact, may lose our ability to log into (at least the website, and possibly the apps too (if you log out and try to log in again). I would appreciate if Telus technical staff could look into that and please advise. And if it is the case, then it would be good to clarify this for customers, and to correct the information that is provided in the transition documentation.  

Thanks for your support.