piktv box keeps switching to chromecast in the middle of watching tv

Reply
Highlighted
Resident
my piktv box keeps turning into chromecast in the middle of me watching tv. it goes on every night! i’m not even touching the remote then all of a sudden it’s chromecast. what’s going on? how do i stop this?

also my piktv remote volume button doesn’t work any solution for that? i have to use my tv remote to change volume. but piktv remote to switch channels.
Highlighted
Community Power User
Community Power User

Chromecast: Do you have any devices that you have previously used chromecast with to cast to the Pik TV box?

 

You may need to re-pair the Pik TV remote. What make and model of TV are you using? 


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Highlighted
Resident
i had a chromecast before but i unplugged it when i got the piktv media box. still happening 😕
Highlighted
Community Power User
Community Power User

@mml wrote:
my piktv box keeps turning into chromecast in the middle of me watching tv. it goes on every night! i’m not even touching the remote then all of a sudden it’s chromecast. what’s going on? how do i stop this?

Additional question. After how many hours since you last touch the remote does it switch to chromecast? Android TV platform boxes have essentially a screensaver where it'll show photos from Google and a chromecast message on the screen after I believe three hours of inactivity.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Highlighted
Resident
Mine does this too. I’ve tried adjusting the screensaver on the box in settings but you can’t actually turn it off. The longest inactivity it allows before it switches to the chrome cast screensaver is only 1 hour. I’ve got it set to put device to sleep never, but it still shuts off. So frustrating to not be able to watch a full show. Who touches their remote every 5-59 minutes in the middle of a movie? This is a recent change in our system and I can’t figure out how to correct it.

I can’t get my PikTV remote to pair with my tv either.
Highlighted
Advisor
Someone else reported a similar issue recently. I think factory reset is your best option:
https://forum.telus.com/t5/Pik-TV/PIK-TV-AND-CHROMECAST/m-p/106555/highlight/true#M3515
Highlighted
Neighbour
Definitive solution:
1. Press G button for main manu
2. Open Settings
3. Open "About"
4. Navigate until selecting "Build"
5. Hit "OK" button multiple times until you see a message telling you are now a "developer"
6. Navigate back to the main settings page ans scroll down until you find "{ } Developer Options" and open it
7. Enable the second switch: "Stay Awake"
8. Done enjoy your Pik TV without interruptions.

Bonus: to improve the TV box overall performance...
1. Go to the same "Developer Options" menu and scroll down until "Apps" section.
2. Enable "Don't keep activities"
3. Open "Background process limit" and select "No background process"

Now you will see a much better performance.