UPDATE: Making Pik TV better and better

Reply
Community Power User
Community Power User

What happens if you take your PikTV device to your brother's place?

 

NFtoBC
If you find a post useful, please give the author a "Like"
eggsbenedict
Neighbour

@NFtoBC wrote:

What happens if you take your PikTV device to your brother's place?

 


Just tried this, the box worked fine, switching between hockey on PikTV Sportsnet and CBC on Antenna was identical in terms of smoothness (though it did show off just how compressed the PikTV signal is!).

 

Brought it back home and the same test there's a clear difference in smoothness. My TV is 4k, my brother's is not.

 

While it's always hard to describe motion in writing, I'll try anyway. It's an inconsistent jerkiness like you get when you first tune to a channel and the box is trying to render the OSD, rather than the consistent stutter you'd see with 24fps content or on the 30fps channels like CBC on PikTV. As if the machine is struggling to render the content. Since content outputted from other apps is fine, I'm guessing there's something going on with the PikTV app's upscaling or deinterlacing at 4K. Unfortunately the PikTV is pretty locked down so I can't mess around with the output resolution or frame rate and try and troubleshoot.

 

This definitely was not an issue before the update, I was watching a baseball game when the update notification popped up, and the change was immediately noticeable after it updated.

 

For what it's worth, the new remote power saving setting where it kills the Bluetooth connection after a few hours makes the box completely unuseable for me anyway, as I have to walk into another room to turn the thing on via IR, since I didn't bother running an IR repeater when I redid all my cabling a couple months ago, as all my remotes connected by Bluetooth. 

Spud387
Friendly Neighbour

@Jeremy2 wrote:
Since update I’m getting back screen stop restarts that last about 3sec in Netflix and Plex. Also the lights on the box go off completely after tuning it to standby and I have to press like volume or something to get the Bluetooth light back then I can turn it on.

Anyone else had similar issues

My box was experiencing zero issues until this update and I now get this issue with my remote. The lights on the box are all off and I have to press a button (volume, OK, etc) to get the blue light to reappear before I can turn it on.

clint17
Coach

Hi all

 

Before the update I had the three main issues with the guide, error 140 and stuttering channels.

 

After the update all the three problems are gone, as of now. Thank you Telus.

 

I had to update the remote fw too. Now after 12h all the Leds on the box are off. Good.

 

1. press ON - remote orange, Box turns green,

 

2. press Guide - remote red, Box green and blue,

 

3. and up,  i.e. Channel - remote green, box green and blue.

 

I'm on a wired connection so no red Led on the box. And I'm using the box only for PikTV, YouTube and Crackle. Everything working fine as expected.

 

Clint

 

Skulchyski
Connector
I still have these issues! Since you posted over a month ago I have little to no hope they will fix anytime soon
Apocalypse21
Resident
Well since this update my tv loses signal from my piktv box about once every 5 minutes or so for 1-2 seconds and then comes back. I’ve reset to factory and changed my HDMI cable with no improvement. Makes it pretty much unwatchable. I’m not clear if this is a hardware issue or due to the update as the timing is suspect....

Is anybody else experiencing this?
Cheezer38
Connector
I have the same issue. It seems like the box lose connection for 1 sec and comes back.  It can happens often every 3-5 mins.  
 
It effects other programs as well not just Pik app.
Allow other android tv to use the pik app. I am not sure if Telus is trying to make money off hardware, but if Telus has problem with the media box, they should open up the app to Nvidia shield, mi box, and nexus tv. They only need to require hdcp like Netflix.

Junginator
Connector
Mine just goes to static and reboots randomly after watching Netflix every few min. Aargh
Community Power User
Community Power User
Have you installed the latest PikTV app update from the playstore.. That was an old bug fixed months ago with a software update

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Matty
Resident

I've had my telus pik for about 2 months now.  Watching TV is painful.  I've had to reset back to factory defaults twice in the past month just to be able to watch the Pik TV.  Netflix drops out a lot, better off to watch on the Smart TV.  Spotify drops out as well.  Is this common or expected?  Seems like a few glitches that a person shouldn't have to deal with in this day and age.  Any ideas to make the viewing experience better aside from a factory reset and unplugging the unit? 

Jeremy2
Connector

@Matty wrote:

I've had my telus pik for about 2 months now.  Watching TV is painful.  I've had to reset back to factory defaults twice in the past month just to be able to watch the Pik TV.  Netflix drops out a lot, better off to watch on the Smart TV.  Spotify drops out as well.  Is this common or expected?  Seems like a few glitches that a person shouldn't have to deal with in this day and age.  Any ideas to make the viewing experience better aside from a factory reset and unplugging the unit? 


This is the pik tv post update unfortunately everyone seems to be having the same issues...