Still lots of issues

Reply
Jeremy2
Connector
Ok so since the update I am having a lot of issues.
1. Overall the whole thing feels slower and stutters between menues /apps / buttons.
2. Can barely watch Netflix most of the time as at random intervals it just goes black for 2 sec then back to the Netflix menu and I have to press play again. Did it 20 times within the last 1hr of a movie the other night did a full power down seemed to help for 30 min again. Maybe a memory issue?
3. Even after the remote update I still come back to all lights off and have to press a button like volume up before it will reconnect and I can turn it on.

I really don’t want to have to call the useless tech support if I get on the phone I know I will just cancel. The roku is already being used again. Can someone from Telus actually acknowledge that the issues people are all having after the update are being looked at?

Jeremy
Skulchyski
Friendly Neighbour

I am having the same issue. 

 

On demand and just shuts the whole box down.

Netflix plays for 5 min then just quits!

 

this is getting worse not better if they don’t fix this I’m switching. 

Community Power User
Community Power User

I have no issues with Netflix or VOD at all on my Pik TV. The box does seem to load a little slower on boot though.

 

For Netflix, have you tried deleting the app and then reinstalling it?

Jeremy2
Connector
I’ll try it haven’t deleted and reinstalled it yet but I have noticed it seems to be only on movies or tv shows over 30 mins not tv shows like Brooklyn 99 so maybe something to do with play length
LucAI
Connector

I've just heard the agonising Sh* yell of my wife when Netflix faded to black for the 10th time while watching a suspenseful series.

Also, the UI is slower - it takes long seconds for the guide to show up. VLC app which I use to play movies from my NAS is stuttering.

It all used to work fine. The update messed it up. If we need more powerful hardware, then Telus should make it available. I'll gladly pay more for a box with a higher WAF (Wife Acceptance Factor).

Highlighted
Jeremy2
Connector
Haha I hear ya. I just did a full factory reset and reinstall seems to be a bit quicker and working a bit better
Jeremy2
Connector

So the saga continues.. now it seems the box cant handle the Netflix auto play as it seems to try play a few times as you scroll through then it starts getting slow then it starts stuttering then i force quits back to the google screen. Also even after the remote updates and factory resets the box still loose Bluetooth connection to the remote. got a call from sales about the box said it doesn't work since the last update. Transferred to tech support (40 min call) had to educate the guy about what a pik tv box is.. told him to check there own forums for a list of issues. maybe we will get some help! overall it feels like they are asking to much of the boxes limited hardware. Plugged my roku back in and the speed difference in netflix and plex is insane.