Pik TV remote programming


This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.


Hello all,


I got a new TV on boxing day and I've been having trouble programming the Pik TV remote to control the TV.

Whenever I get to the "Program Remote with TV/Home Threater" -> "Please select your TV brand", nothing is listed and I can only click Cancel.  I tried auto-programming too but it would say it failed.


I tried resetting the Pik TV box to factory settings and that didn't work.


Any ideas on how to fix this?


Thanks in advance

Most Helpful

Just to cover the bases, can you confirm that the Pik TV box has proper Internet access to download the TV brands? And when you try auto-programming, did you make sure to point the remote at the TV's infrared receiver? Is the system up to date (Settings -> About -> Build NYJ17)? And all the apps are up to date (Google Play Store -> My apps)?


If the issue persists, try resetting the remote: press and hold "apps" and "prev" until the led blinks (3 seconds).

Once you do that, the remote looses Bluetooth pairing info (fallback to infrared mode so you have to point it to the box) until you pair it again.

In infrared mode, each key press will attempt to trigger auto BT pairing in the background. That is not working well for me, so I use my TV remote to browse to Settings -> Remote & Accessories -> "Add Accessory" -> "ruwido BLE" (fails to pair 1st time, click again and it works).


Then try the auto-programming again while pointing the remote at the TV (that part is always over infrared).