Pik TV is a big disappointment and nightmare

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Michelle2
Neighbour
If you are thinking of getting Pik Tv, don’t Long story short...
1 Year
4 different Pik TV boxes
4 all never worked for me and all Telus did was keep sending me new boxes.
Issues - to get is to work I have to unplug every night and reboot every day to access shows. 2-3 times per week I have to factory reset because Pik TV can’t be accessed. This is the biggest kicker. Telus forces you to access Netflix only using their technology but every time I use Netflix I am forced to factory reset after EVERY use. Needless to say I will be leaving Telus and returning to Shaw
clckwrk
Resident
Not sure what else to do with this box... I'm getting random shut downs and reboots and also the common Netflix issue (grayish screen with audio for a minute followed by reboot). I've factory reset the box, updated the Netflix up and still getting this issue several times per evening. Any ideas? Thanks all Smiley Happy.
Community Power User
Community Power User
What version of the PikTV app is currently installed? I don’t have any reboot issues or problems like you stated.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
dominicl
Connector

This looks like a defective box. I would recommend to contact support and get it replaced.

DanielK
Connector

no, this is not hw related. it's a common problem and it occurs on both of my boxes.

clint17
Coach

Hello

 

Same problem here. Newest software version. Since almost two years Pik TV is available on the media box. Actually not really because it's still not working the way I expect it to work. Needs some user action like reset or unplugging at least every second day, goes back into sleep mode after about 90 minutes into a new movie when watching Life TV, etc . Unfortunately I do not know where the real problem is. Being it providing inferior hardware as some people state or being it developers just simply unable to get a software package running without the most basic errors. 

 

I'm using the box connected through cable, wireless off, static IP and I have no other apps loaded. The pre-installed YouTube app works flawless and so does my ROKU on the same subnet, so I'm leaning towards software that is not capable to handle the task. A company like TELUS should have access to people who can handle a job like error free streaming on an Android TV box.

 

Clint

 

dominicl
Connector

Just to be sure, by "shutdown and reboots", you mean the full box reboot including seeing the 2 red LEDs at the front of the box and the "android" boot animation, right? Not just the Pik TV app restarting (the animation looks like the boot animation, so it may look like a reboot).

 

Full reboots are usually caused by hw things like power supply and overheating. Android usually takes care of killing misbehaving applications so they don't take down the system. I have been using the box for 2+ years and seen many issues, but sudden full reboot is not on my list, but my usage patterns may be different than yours. If you find any sequence that helps reproducing, I can give it a try on my box.

clint17
Coach

Hi dominiol

 

No, it's not a full hardware reboot/restart. Since YouTube works fine I tend to blame the Pik TV software or the feeding channel. 95% of the time I'm watching Knowledge so I don't have to mute the annoying ads others are trying to feed me with.

 

Error 1: When I start watching Live TV at 7:00PM and not changing channels, then at 10:20PM more or less the screen goes black. Without interaction it changes to the Android background. If I press Ok on the remote Live TV continues. This error appears regularly if one sequence is longer than an hour, saying it starts at 8:00PM and is supposed to run till 10:45PM or so (Fridays, Saturdays and Sundays on K). It also happens randomly.

 

Error 2: I'm watching Live TV and suddenly an error message appears in the middle of the screen saying something like the application has to restart, reload or whatever. Sorry can't remember precisely. I get a choice of Ok or Cancel. Hitting either or not doing anything brings the app back on track after a while. From the looks I would say it is from the system. This happens on different Live TV channels.

 

Error 3: Channel surfing - After some channel changes, carefully letting the system settle each time after the change, the app locks up. When I'm lucky I can go Home. Settings, About, Restart and the app restarts. If I'm not so lucky and the system is completely frozen then the only option is a power cycle. 

 

I'm on PureFibre 25 with 30 Mbs download, wireless completely off, static IP and no others using the connection. The box is fully updated to the newest version.

 

Marcel

 

DanielK
Connector

WORKAROUND FOUND.

 

The solution to the netflix red/gray static issue with freeze/audio and then reboot is to roll back to the last version of Netflix build 2424. The latest build 2440 is causing this issue. As to whether this is Telus or Netflix as the root cause, it's up to them to figure it out.

 

If you don't want to install from an unknown source like apkmirror.com, then just uninstall the update and it will revert back to the embedded ROM version build 1965.

Highlighted
DanielK
Connector

Sorry, jumped the gun, build 2424 also crashes. Will try an even earlier build later.

dominicl
Connector

@clint17 wrote:

No, it's not a full hardware reboot/restart.

Good, that means the Android logs could potentially provide useful info about the crash and the events leading to it. Do you know how to extract Android logs? It can be a bit tricky, but I can help you do it if you are interested.

 

Like Android phones and tablets, the Pik TV box allows app developers to run and debug their own apps, but also to look at the system logs. To do that, you need to enable developer mode by clicking 7 times on the line that says "Build" in the Settings > "About" menu. (This is not specific to Pik TV, it's the standard Android way of enabling developer mode.) This will add the "Developer options" submenu to the Settings. In the "Developer options", enable the "USB debugging" to allow remote access. Then go back to "About" > "Restart".

 

Although the settings called it "USB debugging", it's actually going to be network debugging, because the Pik TV doesn't have the USB debug port that are usually on Android phones. Note your Pik TV's IP address, you'll use that to access it.

 

On your computer, you'll need the "adb" executable from the Android platform tools to connect to the device. (https://developer.android.com/studio/releases/platform-tools.html)

They are also included in the Android Studio installation if you feel like trying app development ;-)

 

Once you get adb, all you need to do is "adb connect <ip>" where <ip> is your Pik TV's IP address. Then you'll see a popup on the TV asking if you authorize access. After that, "adb logcat" will show you what is happening on the box. You can scroll back and see what happened.

clint17
Coach

Hello dominiol

 

First thank you so much for this excellent tutorial. I will try it out and see if I can get results, and I will stay in touch with you.

 

Have a good day

 

Marcel

 

DanielK
Connector

Managed to capture the crash, thanks for the instructions.

 

Excerpt:

01-18 22:42:37.012  2969  3193 V Avrcp   : MediaController playback changed: PlaybackState {state=3, position=2022576, buffered position=0, speed=1.0, updated=91277524, actions=570, custom actions=[], active item id=-1, error=null}
01-18 22:42:37.368  6062  6062 I chromium: [6062:6062:INFO:CONSOLE(94)] App ID: CC32E753 " [  0.017s] [cast.receiver.CastReceiverManager] Version: 2.0.0.0078", source: https://www.gstatic.com/cast/sdk/libs/receiver/2.0.0/cast_receiver.js?google_cast_bg=true (94)
01-18 22:42:37.371  6480  6496 I chromium: [6480:6496:INFO:media_capabilities_bindings.cc(323)] CanDisplayType type=video/mp4; codecs=hev1.2.4.L153.B0; eotf=smpte2084 (unsupported eotf: smpte2084) -> false
01-18 22:42:37.371  6480  6496 I chromium: [6480:6496:INFO:media_capabilities_bindings.cc(237)] CanDisplayType type=video/mp4; codecs=dvhe.04.06 (unsupported media format) -> false
01-18 22:42:37.380  6062  6062 I chromium: [6062:6062:INFO:CONSOLE(301)] App ID: CC32E753 "document.registerElement is deprecated and will be removed in M73, around March 2019. Please use window.customElements.define instead. See https://www.chromestatus.com/features/4642138092470272 for more details.", source: https://www.gstatic.com/cast/sdk/libs/receiver/2.0.0/cast_receiver.js?google_cast_bg=true (301)
01-18 22:42:37.527  6480  6496 I v8      : [6480:0xace03b80]      796 ms: Scavenge 1.7 (3.3) -> 1.5 (3.8) MB, 5.2 / 0.1 ms  (average mu = 1.000, current mu = 1.000) allocation failure
01-18 22:42:37.599  6480  6496 I chromium: [6480:6496:INFO:html_media_element.cc(514)] HTMLMediaElement(0x2ac03210)
01-18 22:42:37.622  6062  6062 I chromium: [6062:6062:INFO:CONSOLE(1)] App ID: CC32E753 "[eme_polyfills.tester]", source: https://cast.scdn.co/castless/867e539/main.js?google_cast_bg=true (1)
01-18 22:42:37.682  2476  4507 V PlayReadyDrmFactory: createDrmFactory >>
01-18 22:42:37.682  2476  4507 V PlayReadyDrmFactory: isCryptoSchemeSupported >>
01-18 22:42:37.694  2476  4356 V PlayReadyDrmFactory: createDrmFactory >>
01-18 22:42:37.694  2476  4356 V PlayReadyDrmFactory: isCryptoSchemeSupported >>
01-18 22:42:37.694  2476  4356 I PlayReadyDrmFactory: isContentTypeSupported >> mimeType = video/webm
01-18 22:42:37.694  2476  4356 I PlayReadyDrmFactory: isContentTypeSupported >> mimeType = video/webm Supported
01-18 22:42:37.709  2478 16009 I MediaPlayerService: MediaPlayerService::getOMX
01-18 22:42:37.711  6062  6511 I OMXClient: MuxOMX ctor
01-18 22:42:37.713  2478  3089 I OMXMaster: makeComponentInstance(OMX.broadcom.video_decoder) in mediaserver process
01-18 22:42:37.713  2478  3089 V bomx_android_plugin: OMX_GetHandle(OMX.broadcom.video_decoder)
01-18 22:42:37.716  2478  3089 I bomx_video_decoder: NEXUS_Platform_SetHeapRuntimeSettings(3:0xce07e900, open) on decoder open -> success
01-18 22:42:37.818  2478  3560 W bomx_video_decoder: BinderNotifyDisplay: New frame (22088) arrived but previous frame (22087) hasn't been displayed yet!
01-18 22:42:38.081  2478  3089 I bomx_video_decoder: NEXUS_Platform_SetHeapRuntimeSettings(12:0xceb64000, open) on decoder open -> success
01-18 22:42:38.083  2507  2507 W NEXUS   : nexus_statistics_module: platform[Default] nexus/base/src/nexus_base_scheduler.c:949 251 msec
01-18 22:42:38.083  2507  2507 W NEXUS   : nexus_statistics_module: sage[Default] include/linuxkernel/driver/nexus_driver_body.h:155 354 msec
01-18 22:42:38.088  2507  2507 E NEXUS   : Error at nexus/modules/security/src/nexus_security.c:249
01-18 22:42:38.090  2507  2507 I NEXUS   : nexus_platform_core: Detected SECURE MEMC ARCH violation. Terminating....
01-18 22:42:38.408  2470  2801 I AudioFlinger: BUFFER TIMEOUT: remove(4100) from active list on thread 0xa5283680
01-18 22:42:43.421  2440  2814 E bcm-hwc : [chpt]: time out waiting for 5000 ms
01-18 22:42:43.421  2440  2814 E bcm-hwc : [chpt]: checkpoint error: 10
01-18 22:42:43.421  2440  2814 E bcm-hwc : [ext]:[blit]:18446744072333991520:213703:213702: failure to blit.
01-18 22:42:43.421  2440  2814 E bcm-hwc : [chpt]: checkpoint error: 10
01-18 22:42:43.422  2507  2507 E NEXUS   : Error (0xa) at nexus/modules/graphics2d/src/nexus_graphics2d.c:1329
01-18 22:42:43.422  2507  2507 E NEXUS   : Error (0xa) at nexus/modules/graphics2d/src/nexus_graphics2d.c:1329
01-18 22:42:43.622  2440  2814 E bcm-hwc : [ext]:[frame]:213704:213703:grabbing framebuffer FAILED!
clint17
Coach

Hello dominiol

 

Error #1 happened at 22:05PM. I have logs from 20:00PM till 22:40PM (3 files) which might be of interest for you. Please let me know where to send them.

 

Marcel

 

Michelle2
Neighbour
I am on my 4th Pik TV box and having this and all kinds of other issues. My advice is run fast and hard away from Pik TV and Telus because it doesn’t get any better with this product
Michelle2
Neighbour
It doesn’t get better trust me. I have had 4 different Pik TV boxes that never worked properly. My experience with this and Telus has been a nightmare. Cut your losses
Community Power User
Community Power User
PikTV on Apple TV is a smooth greatly improved experience.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
PikLastTV
Neighbour

Without checking specs, I am going to assume Apple TV has more RAM, which probably improves the menu interface for PikTV, which is always clunky.

dominicl
Connector

Thanks for the crash log @DanielK. The log excerpt you posted will likely reboot the whole system (after ~30 seconds). I would like to reproduce this on my box. Can you describe the sequence leading to this?

dominicl
Connector

Hello @clint17, please check in your logs at the time of the error if you see a line with the "F" (fatal) prefix, followed by a few lines that all start with "at ". The "at " lines are the stack trace (the details of which function called which function to trigger the crash)

For example: https://developer.android.com/topic/performance/vitals/crash#reading_a_stack_trace

 

Try to narrow-down to a section around the crash and post that section here. Note: usually one crash will trigger other crashes afterwards (dependencies), so please try to focus on the first crash around that time.