Pik TV doesn't work in a browser

Reply
Squack
Friendly Neighbour

Since the online app switched from Flash to HTML5 I can't get streaming to work. I can log in with either Firefox or Edge. Firefox tells me it's not a supported browser and Edge just stalls with a pinwheel as it tries to load content.

I've made sure that the browsers aren't blocking pop-ups, etc. but I've run out of bright ideas.

Any others with this problem? Solution?

Thanks,

Squack


Accepted Solutions
Most Helpful
WestCoasterBC
Community Power User
Community Power User

Firefox isn’t supported currently: 

 

https://www.telus.com/en/bc/support/article/pik-tv-installation-for-internet-browser


Pik TV on web browser runs on HTML5. Supported operating systems are Windows 8 or higher, Mac OSX 10.10 or higher. Supported browsers include Google Chrome, Microsoft Edge and Safari (version 11 or higher).


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

View solution in original post


All Replies
Most Helpful
WestCoasterBC
Community Power User
Community Power User

Firefox isn’t supported currently: 

 

https://www.telus.com/en/bc/support/article/pik-tv-installation-for-internet-browser


Pik TV on web browser runs on HTML5. Supported operating systems are Windows 8 or higher, Mac OSX 10.10 or higher. Supported browsers include Google Chrome, Microsoft Edge and Safari (version 11 or higher).


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

View solution in original post

Squack
Friendly Neighbour

Thanks but this does not solve my problem - please read my post again.

 

I tried Firefox, but understand it's not supported, which is lame.

I tried Edge, but it still doesn't work.

 

So now what?

Nighthawk
Community Power User
Community Power User

PikTV works for me in Edge and Chrome. Edge is Version 89.0.774.50.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Squack
Friendly Neighbour

Thanks for the suggestion. Edge is not my main browser so I just updated from Version 89.0.774.45 to 89.0.774.50.

 

Same problem persists where the content stalls when loading at the small spinning wheel and/or the icons show up for skip back, pause, skip forward.

 

Any suggestions are appreciated.

KHR
TELUS Employee
TELUS Employee

Are you using a supported operating system? As @Nighthawk mentioned, only Mac OSX 10.10+ and Windows 8+ are supported. ChromeOS, WebOS and other gaming console operating systems are not supported. 

 

Are you using a bookmarked link or navigating from telus.com/watchpik? You may need to clear your cache and cookies, or try incognito/private browsing mode.

Squack
Friendly Neighbour

I'm running Windows 10 Pro, V. 10.0.18363 Build 18363. My laptop is an older model Lenovo Thinkpad T430, FWIW.

 

I completely cleared the cache in Edge and tried. Still doesn't work.

 

I tried it in Edge with a private window. Still nope.

Squack
Friendly Neighbour

Just had a pop up ask to authenticate a certificate with a couple options for me to select. Looks like neither option is listed as a "trusted certificate", so maybe this is the problem? I've never seen this before.

Squack
Friendly Neighbour

Finally got it to work, but only by downloading and using Chrome - blah

Thanks for the suggestions everyone.