Pik TV - blank screen, won't launch


OK, I have set up fixed IP address for my Telusbox, and will see if this fixes my problems... will report back in a day or so





I managed to set my router and Telus Pik box to use a fixed IP address


(I did this so that the Telus box would not get a new IP address assigned by the router after every overnight stop/restart)


unfortunately, the problem is still here and I still get a black/blank screen (with tiny white rectangle in upper left corner) at startup


any more suggestions anyone? thanks


still having the same ongoing issue (every day), and still hoping for a fix by Telus, or further things I can try...


at startup, I get a blank/black screen with small white rectangle in upper-left corner, see PHOTOS below


the only fix is to:

- hit "home" button twice in rapid succession

- will see a list of apps... navigate to the Pik TV app

- scroll down and hit the "X"

- the Pik TV app will then restart, will bring up the rotating dots "Loading" screen

- then Pik TV will work normally for that viewing session

- the problem will come back the next time I want to having a viewing session


here's what I see when I start up and want to watch Pik live TV:




Q: can anyone at Telus acknowledge the existence of this bug, and give an estimate of when it will be fixed?


I have tried 2 different Telus boxes, and BOTH exhibited the exact same behavior, so surely other users must be seeing this


both boxes were carefully set up, fully updated, the Pik TV app updated, hardwired into a stable internet connection, etc., etc. but the problem is there -- every single day


thank you!


I've been having this problem for ages, FYI, that little green icon is an error message from the android system. You can sort of see it when you do the double tap on the home button an look at the apps to be closed, depends on the background of the last channel that was on. 

I'm pretty sure this started to occur a couple of updates ago. I've also been through two boxes and so many factory resets that I can't even count.  I'm so used to dealing with this it's become normal, turn on tv, double click home button to clear apps, launch Pik TV, wait for that to load because for some reason it is incredibly slow to boot up, change the channel if I can because sometimes the whole menu system locks up and if that happens I do restart or unplug it and restart. Like I said, I'm just used to working around it.


Also wanted to mention that my modem mysteriously reset itself back to factory, not sure if or how that's related, just kinda odd.


Qix: thanks for chiming in on this!


you clearly have the EXACT SAME problem as I do, so it's nice to hear there are others out there (and most likely many others...)


my fix is the same as yours: EVERY TIME having to go through all the extra steps, rebooting the app, and waiting -- just to get Pik TV to start up as it should


my wife and kids still don't want to use it, because they say it's too complicated to have to go through all the extra "workaround" steps, and say to me "why don't they just fix it"


so, they're still using our over-the-air-antenna, and I have to be there when they want to watch Pik TV... that's a shame, because once the system is working, I actually quite like it considering the reasonable monthly cost


would really love to get a fix for this bug please... keeping my fingers crossed!


I'm still here, patiently waiting and hoping for a fix for this...........


very tedious having to go through the extra steps every day to clear the Android error and get Pik TV to restart & load


Over the past many days, I have been trying to find a solution to the same black screen appears when I bootup, I rarely get to see the home screen, out of 1 of 10 times the device boots otherwise it keeps sitting there drop dead.  



Pik Tv doesn't seem to be a stable product. Let me know how you can help me with this.. 

 20181213_124032 (1).jpg

Community Power User
Community Power User

How long have you had the device? It has a 30 day return policy, to my recollection, and a 1 year warranty. 


Mine works without difficulty, though I did have to get a replacement at one time.


If you find a post useful, please give the author a "Like"

personally, I doubt it's the box because I have had 2 brand new boxes now, and both did the exact same thing


the odds are tiny that both somehow have/had the same hardware problem, so I'll bet it's an app issue


the fix, to get past the black screen (with Android error) at bootup, is described above


and yes, approximately 1 in 25 times for me, it actually boots up without the error




possibly fixed ???


for the past 2 weeks (approximately from Dec 26th on), this problem seems to have suddenly resolved itself


it does not appear that the Pik TV app has been updated recently


I did nothing at all to my Pik settings


HOWEVER, I plugged in a small DAC into the Pik TV box so I could output 2-channel stereo sound to my stereo system


this DAC unit was plugged in/out several times, and I do not normally leave it plugged in


the DAC was plugged into the optical sound jack (TOSLINK) of the PikTV box, and also, its power supply cable was plugged into the USB port of the Pik TV box


is it possible that plugging this device into the Pik TV box somehow fixed the issue?





Community Power User
Community Power User
Just a coincidence as the actual problem is a software issue with the apk.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

yeah, I figured it was just a coincidence, however I'm pretty thrilled that it's finally working correctly -- at least for now!


RE: "as the actual problem with a software issue with the apk...."


can you please clarify... what is "the apk"?



Community Power User
Community Power User
When you see apps just lingo APK (Android package) is just the file format for the android OS.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

UPDATE: it's approx. 3 weeks now that my system is finally running properly... no more Android error every time I start up Pik TV!


wish I knew how it was fixed though....


Had the pik box for a week now & like everyone else it's a total fail. Do not recommend.

Sound but no picture from the first login. Not sure how I got the picture to work eventually the first time as I was just mashing keys on the remote. Since finding this thread I have tried every suggestion. What works eventually is leaving it unplugged for 12 hours or more. Then multiple login attempts, reboots, cache clears etc. Fun, right?

Not user friendly, what's next, programming in basic using only the remote?

I had the pik box so confused/corrupted it wouldn't let me finish signing in before giving me an error message that I would have to select ok or exit & then attempt to sign in again, having lost all my precious digits I already entered. Finally unplugged it & left it for a few hours & it worked first try after that fiasco.

I left it on overnight after I got it working yesterday thinking I could watch today from the get go but no, it still crashed. Sound but no picture.

How many times should pik update? Only had one so far in a week.

If I stay on one channel too long it goes into sleep mode w/a nice screen saver picture. Hitting ok brings back the picture/sound. Normal?


@cousinjunior wrote:

UPDATE: it's approx. 3 weeks now that my system is finally running properly... no more Android error every time I start up Pik TV!


wish I knew how it was fixed though....

Is yours still working?

Is the DAC worth it?

I would like to run sound through my stereo but really don't want to spend one dime more on something that works barely half the time.


OMG. I'm having exactly the same problem now!! But I've never opened this app successfully........


I found that I can't open it from my phone and browser as well. But I can use it in my office(with internet from Shaw)....Is it the problem of the internet????