Showing results for 
Show  only  | Search instead for 
Did you mean: 


Good morning. After several calls regarding the lp1008 error there is still no fix. We have ensured my account is set up properly (I can easily log in via the telus website and it clearly shows my pik tv active) every time I try to log into the app on either my phone, tablet, or the telus android box i get the lp1008 error. This is very frustrating .

I was thinking it was perhaps due to my internet plan being the 150/150 plan as it no longer exists. Any thoughts? I live in West bank bc which is on a pure fiber network.


I had this problem as well, it started working after a day...ish(cant remember exactly it was a long time ago). I am also on the 150/150 plan so I don't think it would be that.

Helpful Neighbour

Is it working for you now? I have seen on here that a number of people wait 24 hours and it suddenly works. For me, I was told that my box was not properly configured before they sent it so they had to do some back-end magic before I could access the service on my TV and SmartPhone.

Nope not working yet, they told me to keep trying until the first week of jan, then call back.  Not working on the box, tab or phone

I also tried via the pc, same error on that.

Helpful Neighbour

Sorry for your trouble! Makes me wonder if your box was not configured correctly just like mine was. Took a couple hours on the Telus chat before someone on the tech team was able to discover that.

You probably already saw this but just in case...


Yes tried that. I've also spent awhile with telus on the phone. I was escalated up the line to the proper department where they tried everything they could (they called me back a few times to try new things) still the same error.

Still not working. Same error.

Helpful Neighbour

Brutal! Any further conversations with Telus to try and resolve?

Maybe they can overnight you a different box? Anything to get you up and running.

Fixed. I ended up spending around 4 hours on told over 2 days. The lady yesterday wouldn't give up. We ended up having to remove all services from my account and then I added them back on.

Now it works great. There are a few tweaks to make like having YouTube show within the pik tv app and waiting for telus to up date the remote allowing proper soundbar control.

Glad you finally got yours working.  This is basically day 5 with no access to Pik TV and I am now on day 2 with no access to "my account" because they are trying to fix the lp1008 error.  They have been working on it since yesterday, but not having access to "my account" kind of scares me because I can't see what my internet usage has been and/or how much I have left for the month because of the streaming of movies or shows.