Showing results for 
Show  only  | Search instead for 
Did you mean: 

Log your Telus Pik Media Box Failures Here

Helpful Neighbour

This truly is getting so ridiculous, it's almost sublime.


Telus Pik Media Box. Fibre internet. Ethernet connection. Plenty of bandwidth capacity. Should be a representative, classic, performant, customer situation.


If I were to log every day what goes on with Pik... I'd fill up pages. Forum members, please do not suggest another device. I'm using the officially supported Telus Pik device that they sold me. It has essentially never worked as it should - which for a *consumer media device* basically means like a TV. Turn it on, it works.


Every other streaming service manages to work flawlessly on *multiple* platforms. But not Telus Pik, not even on their own, officially "supported" device. Given the preponderance of complaints - and the thousands of others who just suffer in silence, as evidenced by the darkly themed survey Telus conducted of Pik users recently, what does "support" mean? The solution is flawed and hasn't improved in any meaningful way over the past year. Feature improvements mean nothing when stability and responsiveness is so poor.


2019-09-01 Media box "loses" password; forces a re-login. How does the app lose credentials Telus? And repeatedly? This is nonsense.

2019-09-05 Audio missing from TV; trick of going to YouTube to play a video then back to TV "resets". So tiring.

2019-09-06 TV app keeps quitting, returning to "home" menu

2019-09-07 Usual sluggishness, application completely locks up/unresponsive - at least four reboots by me, several by other family members.

2019-09-08 Application Load Time Out - Pik services are not responding AND lost username/password, force re-login. But there's nothing preventing the app from loading, as re-entering username/password brings you in. Way to go descriptive error message Telus!


More to come, guaranteed.


Helpful Neighbour

2019-09-08 Enter Google Play App Store to check for Pik app updates; choose "MyApps"; "waiting" icon spins mercilessly at me - never completes action.

2019-09-08 Search for Pik TV App in play store - element is retrieved instantly but clicking on it "Can't COnnect. Check your internet connection and try again" (internet is 100% here, as always)


Just another day in the life of a Telus Pik Media Box user.

Do you have a WiFi network configured on the box, even though you use ethernet?

Also, assuming you've done a factory reset, does it work okay for a while before eventually encountering all those issues?

That sounds like an above average number of issues. If a factory reset doesn't fix the problems, consider trying to exchange the box?

Helpful Neighbour
Hi there, no, I have intentionally disabled Wi-Fi for obvious reasons.

Factory resets have occasionally improve things for a while.

There's plenty of disk space left on the file system and plenty of RAM available.

We don't use the box for streaming Netflix because it's so hopeless at it, our TV has a Netflix client which works brilliantly.

The only two apps we use on a regular basis on the box besides pick TV YouTube, and CBC gem as of late.


I wish I could offer some more assistance... What you're describing sounds to me like issues that arise from poor network connectivity, but of course it could be a lot of different issues.


No question the Android box is under-powered, but what you're experiencing is certainly way worse than I've ever seen. I've used Netflix a lot on the box and have not had any real issues with it. Other than the channel guide grinding to a halt sometimes, generally everything at least still works.


If I were you, I would rule out any network hardware issues by trying different ethernet cables / ports on the router if at all possible. Hook up a laptop to the same cable you plug the Pik TV into and run some tests to make sure you're getting the full speed you're expecting without any packet loss.


Then I'd factory reset the box, make sure all the apps are updated in the Play Store, and just not install any other apps for a while to see if the issues come back or not.

Helpful Neighbour
Long ruled out connectivity. I have an actual switch, most clients are on wireless: Pik, TV, Chromecast, IP phone, and desktops on Ethernet. If the Pik TV is on, those other devices are almost always idle. Isolating the Pik device to the Telus modem/hub does nothing to change things.

Locking up entirely due to connectivity? Seems less than likely, especially when it's locking up often on the screen saver.

We'll see how long it is before instability returns after the reset. The only visible effect so far is the guide is slightly less sluggish since reset.

Suggested connectivity issues because I ran into similar issues once when I originally got the box - black screens, freezing, getting logged out. Turned out it was bad routing on my switch. Point being: the app doesn't do a very good job of displaying error messages when there are network issues.


Try disabling the screen saver entirely maybe? Sorry not sure what else to suggest. Push Telus on getting a hardware replacement sounds like the next logical step. Shouldn't be as bad as you're describing.

Helpful Neighbour
I think it's not just the Pik app itself, because I have freeze ups even when that app is not running.

Certainly doesn't sound like I'm the only one that's having these sorts of issues though. Many don't have reliable net and sure, that can be a source of many problems, but as managing a complex network infrastructure used to be part of my responsibility, I know that my design at home is solid. Overkill actually.

Still applications and operating systems should throw up useful diagnostic error messages not just hang when the Net is insufficient or unavailable.

Helpful Neighbour
2019-09-10 Clearly there's been an application update applied that wasn't there before as one of the error dialogues looks completely different. but already it's suffered a failed to load application error, I miss the number while I was loading up this email, and it's lost my Telus account.

but I say that the factory reset helped a little bit? Sure, it did seem to, in this period to date - since the reset I haven't seen any lock up switch is an improvement but time will tell.

But despite that reset a couple days ago, I already have a device that won't log in (without me having to answer in the credentials again) to the Telus Pik service, on Telus own network, using Telus own device.

Seems odd, doesn't it?