Showing results for 
Show  only  | Search instead for 
Did you mean: 

Channels not loading on Apple TV

After using Pik TV on my Apple TV for months and never having an issue, I’m suddenly receiving error messages when trying to load a couple of channels. On one it reads: “Playback Error can not reach rights server”, and on another: “Playback Error timeout loading manifest”. Other channels work fine. I’ve forced closed the app, disconnected the power, and reset. No luck. Any advice?

TELUS Employee
TELUS Employee

Hi all,


Thanks for the updates. Our tech support and QA teams are aware of the issue and are trying hard to find a resolution. Appreciate your patience and understanding as we work through it. 

View solution in original post


Community Power User
Community Power User

What channels are you experiencing this issue on?

City and W Network

TELUS Employee
TELUS Employee

I noticed the same thing last night during the third period of the Canucks game. It seemed to resolve itself after a couple of minutes, but I'll check with our technical teams to see if there was anything like an interruption of service from our content providers or network issues last night.

Just Moved In

I am having the same issue with Global and W network. Any suggestions?

I’m still having this issue with W Network. The channel only works through the PIk TV android box. Not on the apps on my iPad or Apple TV. Going on 4 days now. I might have to suck it up and make a call.

I am having the same issue with Global TV.  It's been over a week.  I can sometimes get sound but no picture or a very blurry pic.

Same here.  "Timeout loading manifest"

I deleted and re-installed the app as well but problem remains

Other channels are working fine.


Same, here, about a week global Omni aptn. Does tech support even reply to this forum?

Let’s make that now Channels 104, 120, 125, 128, 329 that are having this error. I thought tech support was pretty responsive here, but so far no luck.

TELUS Employee
TELUS Employee

Hi all,


Thanks for the updates. Our tech support and QA teams are aware of the issue and are trying hard to find a resolution. Appreciate your patience and understanding as we work through it. 

I’m happy to hear you are aware of it! Thanks for the update!

Adding insult upon insult after receiving my monthly bill for a crippled service, I got locked out completely after retries with the response PLAYBACK ERROR “max sessions exceeded”

It doesn’t matter whether coming from guide or icon.

select channel..

- after 10 sec. get a freeze frame of the programs promotional photo, menu will not back out so have to long press to restart app

- if longer than 10 sec. get “timeout loading manifest”. OK icon depress will return to guide.

- if lucky enough to get response with little wait, it is just a freeze frame of what would have been playing, or program appears in SD for a short period before locking, or promotional freeze frame with audio playing in background. If it doesn’t lock up, it just boots all the way back to the app icons by itself. Other glitches I don’t recall at this time, but an echo of other users above in this complaint.

Honestly, my leisure time could be better spent than trying to remember which channels to avoid that interrupt my service, or holding on the phone for tech support in that medium.

Is there a foolproof way to empty all this detritus to avoid what seems to be bloating hang ups, resetting back to a clean setup?

This is happening on every device I’ve tried iOS or Android. Actually on my android phone I get error 4-44-100 if trying wirelessly from my Telus modem, but streams fine using data service.

The only problem channel tried was global 104 due to mounting frustration, but mine also has trouble with apt and omni.

Hi @JokeLark 


I checked into the issue you've been experiencing regarding too many streams in use and I believe we have a fix that we will have to do on your account. I'm going to send to you a direct message to clarify a couple points, but then we should be able to get you up and running again.


How do I get in touch with a local telus you have done? I have this issue and it's driving me crazy - ready to throw away my telus. Also have double (sometimes more) channels audio coming on at the same in took me to India - he blamed my apple equipment.

Any update on this.

For myself (I know others have challenges with different channels), I try to watch Global TV and I see either the manifest error or the channel just renders for a few seconds.

I understand Telus is working on the problem.

Just curious to understand why the problem seems to occur on some channels but not others.


Community Power User
Community Power User

Perhaps it’s some sort of coding glitch that isn’t easily replicated so have to monitor till it pops up on their end.

@WestCoasterBC  @BlairP 


Sorry for the delay on this one, we're having a difficult time reproducing the following two errors:


  • “Playback Error timeout loading manifest”
  • “Playback Error cannot reach rights server”


I may require some of Neighbourhood's help to gather more information to pinpoint the issue. I've heard that people have seen it across various devices, but if you could tell me what channel you experience it on as well as what device that would be helpful.



I’ve noticed problems playing back on demand content on the pik tv app on the Apple TV and iPad. 

Specifically the walking dead and gold rush shows.