Changing channels

Reply
Qix
Connector

So I have been trying to log into my account to change the selected channels but every time  I select manage on PikTV all i get is a blank screen, anyone else having this problem? I can't even use the feature on the bottom of the page to leave feedback on the website.

thecachetyeg
Neighbour

I am having the same issues.  I am unable to change channels or add new ones.  When i click on the link it takes me to a white screen.

K-D
Moderator
Moderator

Hi @Qix , sorry that you're having trouble with the website. I'd recommend clearing your browsers cache and cookies and trying again, or using an alternate browser yo make changes. If you're still unable to change your channels if you give our team members a call at 1-888-811-2323 they can assist with changing the channels on your Pik subscription. Happy New Year!

wmark
Friendly Neighbour

I have the same issue. I have tried several different browsers and devices, all show the same blank screen when clicking the manage channels link

Qix
Connector

Maybe instead of all that Telus could fix their website?

I have tried different browsers and different devices.

I have cleared the cache and tried incognito mode, but it all ends at the same place.

I'm left staring at a page with no information.

The other services I have, home phone and internet, I'm able to go to manage without problem.

So I'm pretty sure the problem is not on my end.

I'm going to strongly suggest that this is a Telus problem and instead of dumping it on the users perhaps they could fix it.

Qix
Connector

So this is definitely a Telus problem.

I just got off the phone with support after changing  a channel and I thought to try and log in again.

Of course I was able to log in and see the management page without error.

Nothing on my end has changed, So much head shaking...

 

 

KHR
TELUS Employee
TELUS Employee

Hi @Qix and @wmark 

 

I'm sorry for the inconvenience. I have brought this to the attention of the team in charge of the website. To help us troubleshoot, are you able to share whether you're on a Pure Fibre internet connection or copper? They use different back-end systems so this will help us isolate where the problem may lie.

 

In the meantime, if you want to avoid calling in, you could try the chat function.

 

Thanks for your help and patience!

Qix
Connector

Copper connection

wmark
Friendly Neighbour
I use pure fibre. When I tried chat support they had the same problem when they tried to change channels on my pik tv account. Guess I should try phoning in again
wmark
Friendly Neighbour

I just got an update for the MyTelus app, and when installed I can actually see and change channels in my PIkTV bundle. Finally fixed!

thecachetyeg
Neighbour
I’m on Pure Fibre and having the same issues. I haven’t been able to change my channels for 2 months now. I’ve tried different browsers and devices.
yclept
Neighbour

I was told that the problem is that I am using Safari, not Chrome...wtf?   Telus is a huge telecommunications company that sells Apple products, and they can't fix a link in their own website?  Complain about a problem here or via feedback and it goes nowhere.  I live in a rural area and we have only Telus or Eastlink to choose from. Telus has great tech (fibre optic years before Vancouver because the chairman of Telus leaves here) and the worst customer service, and Eastlink has worst tech and the best customer service. After a month of complaints from customers there is no excuse for not having fixed the channel swap link; we should not have to call or chat a rep to get a simple swap done.

yclept
Neighbour

I was just told it's because I'm using Safari and not Chrome.  Wtf...Telus sells Apple products and can't solve this problem???

jordandev
Resident

Same problem. I just signed up and can't change my channels or even subscribe to Sportsnet like I want to. Just a spinning loading screen. This is with PureFibre.

 

Have tried both Firefox and Chrome.

 

This is enough to make me want to cancel my service on the first day......

jordandev
Resident

After trying everything it finallly works through the new Edge browser. Firefox/Chrome/IE all didn't work.

 

So try Microsoft Edge if you haven't.

 

Obviously the website needs to be fixed here.