cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

tv freezes every few minutes

twizzle49
Just Moved In

Live in Vancouver and have had this problem for a while but it's worse -even tho Telus came out at one point and thought they fixed it.   any ideas?

1 ACCEPTED SOLUTION

WestCoasterBC
Community Power User
Community Power User
You will have to reach out to Telus and schedule a service call. Unfortunately there isn't s a quick fix, that can be done.

There maybe an issue with the wiring in your home, hardware failing, or Telus equipment outside. It will require a tech to diagnose the issue.

Best to reach them via live chat (does not work on mobile devices) or give them a call https://www.telus.com/en/bc/support/contact-us?INTCMP=TcomFooter_contact_us

View solution in original post

4 REPLIES 4

WestCoasterBC
Community Power User
Community Power User
You will have to reach out to Telus and schedule a service call. Unfortunately there isn't s a quick fix, that can be done.

There maybe an issue with the wiring in your home, hardware failing, or Telus equipment outside. It will require a tech to diagnose the issue.

Best to reach them via live chat (does not work on mobile devices) or give them a call https://www.telus.com/en/bc/support/contact-us?INTCMP=TcomFooter_contact_us

Had the same problem last year. My moms tv was freezing and Optik tv signal lost every night or few days, it was a yellow copper connection out in the concrete underground box beside street, it was in water, so they pulled it out repaired it and a day or so after it works great be every so good now, tho now getting fibre optic this month. So won't be a problem anymore

Also live in surrey

TruckerJim
Just Moved In

I had this problem and it didn't matter what channel I was on. picture would cycle on and off about every minute. Rebooting the tv box didn't help. I then rebooted the modem (unplug power supply for 10+ seconds) and on first try no connection to the internet at all. On second try the modem wouldn't even come on (no lights), and I was suspecting a power supply problem. On third try the modem did reboot and everything came back and the tv channels no longer cycled on and off. It appears the modem may be defective and overheating causing this problem. I will be monitoring this until I move and upgrade.