Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to login to new TELUS TV+ app on iOS and iPadOS


I've downloaded the new TELUS TV+ app but have been unable to successfully login. When I try to, I receive the following message: "Login failed. The app can't connect to the server. Check your Internet connection and try again."


Occasionally I notice that the login form briefly displays email and password fields but they are almost instantaneously hidden leaving only the Log in button. If I do manage to tap the email field before it disappears, I can fill it in but the login still fails.


We've called Customer Support several times over the past few weeks and are struggling to even get them to verify the issue (they seem to lack access to an iPhone or iPad for testing purposes).


Community Power User
Community Power User

Which version of iOS / iPadOS are you using? Which iPhone model is it?


Have you tried:

  • going into Settings (main settings on iOS/iPadOS)
  • Scroll down and tap on TV Provider.
  • Does it give you the option to Sign Out? If yes, sign out and then go back to log in to TV+ again.


I have an iPhone 13 and I am able to log in to the TV+ app without experiencing the same issue.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

View solution in original post


Thank you for doing the work to figure this issue out, worked for me on my ipad after a couple frustrating days.

Friendly Neighbour

Followed your steps Sugata and it now works.  Thanks so much


If this helps, I am confirming that the accepted solution helped me as well.  Thanks for everyone on this post for their contributions.

I have 2 Apple TVs and an iPad and on Sunday March 5 I could not log in to the TelusTV app on my Apple TV.  I logged out of all instances of TelusTV and as instructed logged out of the TV Provider in Apple Settings.

I also noticed that I had multiple Telus entries on my laptop in the Apple Keychain app.  I had used those previously to log into my Telus account as well as access PikTV in the browser in the past.  This included an old password in the Apple Keychain app.  I removed those entries as well.  

Then, as instructed in the Accepted Solution above, I deleted and then reinstalled the TelusTV app.  I did not use the Apple IOS TV credential option and manually entered my username and password.  It worked and I can now view TelusTV on both Apple TVs and my iPad as well.

Hope this helps

Isnt working for me either. I even followed the steps above and when I get to sign into the app I put my info in. It then thinks for a while and eventually seems like its done but then im actually still not logged in…. Been days now

Looks like you still have Telus TV plus as a registered TV provider. You need to take that off

I actually just got it working by going into tv provider in my iphone settings like mentioned above. But instead of signing out in, i just unselected telus tv+ with the slider. Then opened the app and signed in and voila.


I was having a problem getting subscribed channels etc on my iPad for about a week but they finally fixed the problem yesterday.

Thank you Telus

Friendly Neighbour

Dollars to donuts Telus was stumped until they read the solutions provided by Sugata and other customers.

TELUS Team Member
TELUS Team Member

Hi Everyone, a fix was implemented to address the impact to the Single-Sign On flow. Majority of you should be able to log in now. If you are still experiencing issues, please re-install and follow the steps provided by @Nighthawk and @Sugata. If you are still having trouble logging in, then there may be an issue with your account and I'd recommend reaching out to our agents, you can do so through the smiley box in the bottom right corner. Thank you for everyone's help and patience!