Showing results for 
Show  only  | Search instead for 
Did you mean: 

Remote recording access stopped working


It's bad enough that the Neighbourhood forum is all screwed up now and I have to re-login every time I vist. Now remote recording just quit working.

I've been using it for 6 months, but this time when I ran it, it told me that I have to allow Telus to run Silverlight. ?? ok, fine, I allowed it, and it launched successfully.

A few minutes later I tried it again, and this time it hung with Silverlight not responding.

Killed the browser and tried again. This time it told me that my password isn't correct (it is!). I tried a few more times, with Silverlight hanging erratically, and then it told me I have been locked out of my account, look for an email from Telus.

I get an email with a link to "recover my password" (I know what it is! The question is, why doesn't Telus know??). But I click it anyway, and it takes me to a generic information page about remote recording. How does this help me?

Getting annoying!

So I did the total reset and start again with remote recording setup. Went through all the steps again. Restored my original password. Now it works again - for the moment.

What the heck is going on with Telus?


Community Power User
Community Power User

They know about the login bug. We've all been complaining about that.

I assume the Silverlight page you are referring to is ?

I haven't had any issues with the site so far and can load that just fine in Chrome and Firefox. Can set recordings, scroll thru guide. No issues here. It's likely something on your end with your browser and Silverlight plugin. Or someone got your password and changed it. If that's the case check your PC for spyware.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂