Optik on the go => Live TV on laptop?

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Community Power User
Community Power User

@Nighthawk

I've now found my way through to the 10000/3222 error when trying to watch live TV: 'An error occurred retrieving the video. Please try again.'

 

Looks like a major re-work of the software will be necessary of it to function for Safari, and Microsoft Edge Browsers.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

Microsoft Edge does not have support for Silverlight or ActiveX and never will. Microsoft is transitioning away from Silverlight in favor of newer tech that doesn't require plugins (primarily HTML5). Silverlight is dying and Microsoft is moving away from it. There will be no re-working of the software since it's been effectively discontinued aside from the odd security update. That also means Safari support is going with it. Chrome has already dropped support for it since Chrome 45. For OSX, If 10.6 and under, support ended in 2014. For 10.7-10.11 on Firefox 42+ & Safari  6.0+, support ends 2016/12/31.

 

Silverlight system requirements - Has footnote *** Silverlight is not available in the Microsoft Edge browser, but is supported in Internet Explorer.

Microsoft's Windows Blog

 

Microsoft Edge and Silverlight

Support for ActiveX has been discontinued in Microsoft Edge, and that includes removing support for Silverlight.  The reasons for this have been discussed in previous blogs and include the emergence of viable and secure media solutions based on HTML5 extensions.  Microsoft continues to support Silverlight, and Silverlight out-of-browser apps can continue to use it.  Silverlight will also continue to be supported in Internet Explorer 11, so sites continue to have Silverlight options in Windows 10.  At the same time, we encourage companies that are using Silverlight for media to begin the transition to DASH/MSE/CENC/EME based designs and to follow a single, DRM-interoperable encoding work flow enabled by CENC.  This represents the most broadly interoperable solution across browsers, platforms, content and devices going forward.

 


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Community Power User
Community Power User

@Nighthawk  

 

Sorry, I meant  rework of the Optik on the Go software to use HTML 5 or similar.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

Sorry, agreed. The company behind all of those apps will have to rework things and I hope they get it done soon. HTML5 does pose it's own challenges. I've been trying to get around those limitations for something I'm working on but haven't found a solution yet.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Highlighted
Pops
Organizer

You are very knowledgeable.  Wished I was.  I've never been good at digging in to fix stuff for PC's.  If you ever hear of a solution etc, that even us tech challenged folks could or should hear about, it would be greatly appreciated.   

Pops
Organizer

Issue not on my end or specific to my mac.  chatted with Win 10 users who also have issues.  What is obvious is Telus not bothering about the whole business.  Should not be this much trouble to use one of their features.  

Community Power User
Community Power User

Again, Silverlight is the core of the problem. It's outdated and essentially discontinued. The current release of Silverlight released 5 years ago so it'll likely have issues with newer operating systems and browsers, if the browsers even support it anymore (Chrome, Edge don't). Newer versions of Mac OSX and Windows 10 included. This has nothing to do with Telus but with Microsoft neglecting their Flash-wannabe plugin for years. Until the HTML5 replacement is out, you will likely have issues since both Apple and Microsoft have made fairly major changes in the way their OSes work.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Most Helpful
WestCoastD
Resident

***FIXED*** I figured out how to get the Silverlight issue working with Safari on a Mac. Updated to MacOS Sierra today and its WORKING!!

 

If you already have Silverlight installed - Open Safari and Navigate to the Optik On The Go website. https://onthego.telus.com

 

Log into your account and attempt to watch any channel, you will get the same error.

 

Then, in the main menu bar, go to the "Safari" dropdown menu and select - "Preferences"

 

The choose "Security"

 

Beside "Internet Plug-ins" - click the button "Plug-in Settings"

 

Find and highlight "Silverlight"

 

On the right you will see "Currently Open Websites". Beside onthego.telus.com change the dropdown option to "On"

 

Click "Done" and you should be good to go.

 

It worked of me, I hope that works for you all as well.

 

wtbleep
Resident

I spent over an hour and a half with an agent today and still no solution.  I was told it is an issue with mac and the silverlight so until Telus can fix it no Optik on the go for those of us using Mac.  Guess we don't rate for internet tv.  Will never switch back to windows so guess it's goodbye to Telus.

Community Power User
Community Power User
Read the solution above works fine on a Mac. On a windows machine it pretty much plays instantly. When on my Mac it takes 20-30 sec before the video plays.

The entire optik on the go was the framework from microsoft who long sold out. Ericsson "media room" holds the cards now to get with the times and leave silverlight.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

@WestCoasterBC

  Unfortunately for me, it worked the first time I tried it but not since.  Have upgraded to the latest Silverlight today, but it still goes through the motions, but does not work.  I expect I'm not alone. It's really sad that the solution worked for me, but only once.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

@NFtoBC

 

Weird works fine here besides the delay (20 - 30 seconds or so) in playing the video. On Sierra 10.12.1 but shouldn't make a difference.

 

Screen Shot 2016-10-31 at 3.23.21 PM.png

 

Screen Shot 2016-10-31 at 3.26.10 PM.pngScreen Shot 2016-10-31 at 3.26.33 PM.png


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

@WestCoasterBC

Same settings. Possibly an older computer than yours?

Screen Shot 2016-10-31 at 3.45.21 PM.png

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

@NFtoBC The plot thickens.. Smiley HappyScreen Shot 2016-10-31 at 4.00.03 PM.png


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

@WestCoasterBC

 

Graphics card?

 

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

@NFtoBC

 

Graphics card shouldn't really matter. I can tell when silverlight plugin kicks in i have the loading sprite going it freezes for a split second after 20sec or so then video appears.


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

@WestCoasterBC


@WestCoasterBC wrote:

@NFtoBC

 

Graphics card shouldn't really matter. I can tell when silverlight plugin kicks in i have the loading sprite going it freezes for a split second after 20sec or so then video appears.


Mine freezes for a split second restarts, then goes to a blank screen below the Live TV - channel information. Seems Silverlight won't paste the video frame in the window. The footer information remains on the screen.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Dwayne626
Neighbour

Ive spent hours trying to solve the problem.  I finally figured out the silverlight problem now it just never plays video.. Telus tried telling me as well it was my mac. I have two different MacBooks with the same failed result.  Im going to keep pushing these guys to give me a proper answer and  let you know soonest..Im peeved!

Dwayne626
Neighbour

Im having the same issue

Community Power User
Community Power User

Seems it works on iMac but not MacBook 

 

 

NFtoBC
If you find a post useful, please give the author a "Like"