Optik on the Go App will not let me login or reset password


I have used the optik on the go app a few times before without any problems. Now when I go to login, it tells "the Log-in Information you provided is not valid. Please try again."  which may be true. I have tried every password it could be, and will not work. So then I try to reset my password and it says "We are currently experiencing technical difficulties. Please try again." It has been saying this for like a month (last 4 or 5 times I tried to go on to reset it). Even on my computer browser it is doing the same thing. I also deleted the app and reinstalled it, and made sure the location services is on for the app on my iphone . Confused face Smiley Frustrated

Community Power User
Community Power User

There has been a number of reported problems with Optik on the Go, as it requires Microsoft Silverlight to run. Unfortunately, Microsoft is not updating the  Software, so Optik on the Go cannot use it. Similarly there are problems with the App on various phones. To learn some of the challenges users face, search for the term 'Optik on the Go' on this site.


Sorry I don't have a solution to offer.


If you find a post useful, please give the author a "Like"

I'm having the same problem, any luck?


I tried for a while with much frustration but I just could not login or reset my password from my phone app.      I just had optic fibre installed so I think it must have erased my logon information.   I followed instructions on my tv menu and had a new confirmation code sent to me in my email.    I was then able to logon to optic tv on the go and the optic recordings without any further error.     I did not redownload the app and it all seems to work ok.