Optik 4K issues with Sony Bravia 4K TVs

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Helpful Neighbour

I was told by TELUS support that a select Sony Bravia 4K TVs have issues with the Optik 4K PVR. Do you have a list of specific Sony 4K models that are affected by this issue? 

Highlighted
Community Power User
Community Power User
Exactly what issues?

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Helpful Neighbour

I was hoping if you could shed some light on that. The issue has something do with HUE and the only workaround is to set the 4K PVR to 1080p which doesn't make sense at all.

Highlighted
Resident

Same issue here. Image is 4K but color is lost. Rep asked if I had a "Sony XBR" TV (which I do) and said there would be an update coming to the set top box to correct the issue.

Highlighted
Helpful Neighbour

what XBR model do you own? mine is an HX850C. will see on Sunday. Smiley Happy

Highlighted
Resident

I own a brand new (2016) Sony 4K TV set in april (XBR55X930D) - The 2 4k resolution gives green skin and blue lips.  A firmware from Sony is available few weeks later and the 4k work normally

Neighbour

I have a Sony x940d and I'm having the same issue.  However, the 4k broadcast on 1080p looks significantly better than 1080p.  Does that mean the picture is in 4k regardless of the aspect ratio setting? 

 

Telus support just told me they have not ETA for the firmware fix.  Really annoying as this was the only reason I switched from Shaw.

Highlighted
Resident

I'm in the same boat. I bought a 4K Sony TV and had Telus install 4K Fibre Optic at my house. My plan was to watch the Olympics in 4 K. So that turned out bad. Seems like a case of over promising and under delivering.

 

i just called Telus for a date for the fix. They said it would be sometime this Fall. As far as I'm concerned "in a couple of weeks" and "sometime this Fall" is not the same thing.  

 

This information should have been made known before I signed on with Telus.

Highlighted
Helpful Neighbour
no luck with HX850C model. the screen turns pink when using 4K resolution.
Highlighted
Helpful Neighbour
yup it is better than 1080p, i guess the output is upscaled to 4K.
Highlighted
Neighbour

apparently, the issue is with the Arris 4k box not the Sony tv

Highlighted
Community Power User
Community Power User
A fix will come just have to be patient (Telus is aware of it). As an early adopter one can expect some bumps in the road. I like to wait a few months for a product to get rid of the bugs, before I purchase it.

Besides the olympics not much 4K content is available. But you're ahead of the curve when more channels become available. Any issues with the software should make the box bullet proof sooner rather then later.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Neighbour

They shouldn't advertise 4k if it doesn't really work.  That's the sole reason I switched, otherwise I would've just stayed with Shaw

Highlighted
Resident

I just learned about the hue problem with Telus 4K box but only after buying Sony XBR 55 UHD TV last week. When the Telus Box is set on the recommended 4K aspect the picture goes a pinkish hue. When you talk to Telus about it the say that this is the first that they heard of the problem. 

My question is will this issue be corrected or is it best to return the TV? Has anyone else found a solution?

Highlighted
Helpful Neighbour
Unfortunately, some Telus agents are not aware of this issue. I was told by one of the agents(thru chat) about this a long time ago, weeks before the olympics started. He also mentioned that Telus will be pushing a firmware upgrade this fall to fix the issue, hopefully.
Highlighted
Resident
The reason the 4k broadcast in 1080p looks better then the regular broadcast is because Telus uses less compression on the 4K feeds. So even though its 1080p its a less compressed feed and naturally looks better with way less pixelization. Pixelization and the smudgy look in sports is caused due to too much compression. All regular HD broadcasts would look better for everone if Telus didn't use so much compression on their broadcasts!
Highlighted
Neighbour
Whoops... just posted about this... if anyone has a reciver (I have the Sony 1040) that has 4k pass through at 24 or 60hz that will work on the tv. Temp fix till Telus gets it sorted....
Highlighted
Helpful Neighbour

Telus will be pushing a new client upgrade for 4K boxes between Oct 11-17 to fix the pink screen issue on some Sony TVs! Yay!

Highlighted
Connector

That's great news.  How will we know if the update is pushed to our 4K PVR??

Highlighted
Helpful Neighbour

you should see a power indicator when you turn on the 4K PVR, before there was none.

Highlighted
Community Power User
Community Power User

Under Settings>General>System information

 

Client version will state the firmware revision #


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Connector

My client version is 3.0.32900.440 and 4K issues still remain.  I'm guessing the new firmware isn't pushed to my 4K PVR yet.

Highlighted
Community Power User
Community Power User
Once that changes you know you have the firmware pushed.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Helpful Neighbour
the new client version should be 3.1.33566.453.
Highlighted
Connector
Did this update get pushed to your pvr already?
Highlighted
Helpful Neighbour
yup. yesterday.

--
Sent from Gmail Mobile
Highlighted
Connector

And your pinkish issue is resolved? What's your Sony tv model number?


@Wangbu wrote:
yup. yesterday.

--
Sent from Gmail Mobile

 

Highlighted
Helpful Neighbour
Yes. The pinkish issue is resolved. Mine is an XBR850C.

--
Sent from Gmail Mobile
Highlighted
Connector

That is encouraging.  Mine is xbr55x850d.  


@Wangbu wrote:
Yes. The pinkish issue is resolved. Mine is an XBR850C.

--
Sent from Gmail Mobile

 

Highlighted
Connector
After reading this forum tonight I restarted my PVR. I got the new update. I have a Sony bravia x810. Never had the pinkish 4k channel issue. But always had a problem with the HDMI handshake. Once I turned the PVR on and tv I always had to switch the input to another then back. Very frustrating. That issue seems to be resolved. Not having the power led indicator made it even harder to tell if the box was off or on. I like the power led indicator. Wish it was a soft white not red but what can you do. Now just waiting for the Netflix 4k app. I would of thought it would have been added to this update